Page MenuHome

Left mouse kills active tools
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.60

Blender Version
Broken: version: 2.81 (sub 1), branch: master, commit date: 2019-08-12 19:46, hash: rB1a8dccd70aea

Short description of error
OK, this might not be a bug ,but just not knowing how the active tools work. One thing I noticed is releasing left mouse kills active tools and you can't change any other settings.

Active tool

Operator

Exact steps for others to reproduce the error
Active Tool

1: Go to edit mode and select a edge on cube
2: Select "Bevel" active tool
3: Hold left mouse and drag to activate tool
4: Release left mouse to scroll middle mouse for segments
5: Active tool just got killed and you can't change segments, cause pressing the left mouse is tied to confirming operators

Operator

1: Go to edit mode and select a edge on cube
2: Ctrl + B to start bevel operator
3: Scroll middle mouse for segments
4: Confirm with enter or left mouse
5: Operator didn't get killed by releasing left mouse button

Now, one thing I did notice is when you hover over active tools it gives the shortcut for the operator. If you're suppose to activate with the shortcut instead of left mouse, then why even have active tools if you just use the shortcut for operators?

Details

Type
Bug

Event Timeline

OK, looks like this is a keymap issue. Not sure why "Confirm on Release" is on by default.

Germano Cavalcante (mano-wii) closed this task as Invalid.

This seems like it belongs in the paper cut thread and not the bug tracker:
https://devtalk.blender.org/c/user-feedback/paper-cuts