Page MenuHome

Object disappeares with the mask modifier if there is no vertex group on the mesh
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.15.0-58-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.40

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
2.79 as well

Short description of error
Just noticed this behavior. If a mesh doesn't have a vertex group with at least one vertex in it, then the object disappears with the mask modifier in use. Vertex group option in the modifier is empty.
I don't know if it's a bug or it is by design. But anyway, this is not very intuitive.

Exact steps for others to reproduce the error
Create an object
Assign the mask modifier
Object vanished
Create a vertex group with at least one vertex and the object comes back

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Well, behavior is logical here, since we only keep vertices which *are* in the selected vgroup, if there is no selected vgroup or the selected one is empty, then whole mesh is hidden... Note that is you use the 'inverse' double-arrow button, then whole mesh is shown in those cases, as expected.

So no bug here, modifying that behavior would be a design topic, that shall not be handled here. thanks for the report anyway.