Page MenuHome

UI snapping popup window doesn't properly resize when the header is in the bottom
Closed, ArchivedPublic

Description

System Information
Operating system: All (reproduced in Mac and Linux)

Blender Version
Broken: git master

When the header is in the bottom the Snapping popup window resizes when it needs more space but it doesn't resize back when it has too much space.

Exact steps for others to reproduce the error

https://i.gyazo.com/55ef38c43a0a7a8e0c4c1caa500a2a4c.mp4

Reported by Jellbelle in devtalk:
https://devtalk.blender.org/t/blender-ui-paper-cuts/2596/3151

Details

Type
Bug

Event Timeline

Luis de Bethencourt Guimera (luisbg) triaged this task as Confirmed, Low priority.Thu, Aug 15, 3:59 AM

i cannot confirm this problem on linux Blender 2.80-4074ab361e13 AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 430.40, for me work fine


Please, update this report following strictly this template

Next time you want report a bug you can use Help > Report a Bug item and strictly compile following proposed template, all text from [ to ] must be edited. Clearly describe steps to reproduce issue and attach a simplest possible .blend file as request.
Before you made a new bug report you must use Search box (upper right) to check if bug/issue is already reported from others users. Duplicating bugreport is a waste of time and resources for developers

William Reynish (billreynish) closed this task as Archived.

This is an inherent problem with popovers spawning from the bottom, and one of the reasons why headers are on the top now.