Page MenuHome

Cut function in sequencer confused with copy and paste and should be renamed into Split
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Linux-4.15.0-55-generic-x86_64-with-Ubuntu-18.04-bionic 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.81 (sub 1), branch: Unknown, commit date: Unknown Unknown, hash: rBUnknown

Short description of error
Cut function in sequencer confused with copy and paste and should be renamed into Split

Exact steps for others to reproduce the error
Look at this:

Cut, Copy and Paste are in one block, so users might think that they perform similar task, because Cut, Copy and Paste in other programs always placed nearby:

In Sony Vegas and Audacity this function called Split, So i think this function in sequencer should be renamed into Split to avoid confusing

Details

Type
Bug

Related Objects

Event Timeline

Philipp Oeser (lichtwerk) claimed this task.

Thx for pointing out, but to me this doesnt sound like a bug.

  • there is already a separator in the UI between [Cut Hold Cut] and [Copy Paste ...]
  • renaming a tool just because the name is used for different things (in different contexts) does not neccessarily make it better.
  • I mean it could be changed, but that sounds more like a feature request that could go to https://blender.community/c/rightclickselect/

I will close this [unless @Richard Antalik (ISS) or @William Reynish (billreynish) have objections?], thx for the report anyways!

It’s not a bad point. Split certainly would remove ambiguity here.

+1 for split.

For the exact same reasons was Cut renamed to Split(as in separate) in the VSE Reworked Project, and then Cut could be used in the traditional cut/copy/paste sense(as in remove(extract/lift)):

Nb. on the shortcut, in ex. Premiere Ctrl+K is split active channels and Shift + K is split all channels. This way the industry standard of playing J(reverse), K(stop) and L(forward) can be preserved. Currently it is only K(for cut) which is the way for assigning the industry standard J,K&L playback controls. So maybe it is worth considering assigning Ctrl+K for Split.

You can rename this, or I want to work in this area soon so I can also.

Cut is a term of art in the film and video editing world.
Are we building a video editor or a word processor?

I just put up a patch: https://developer.blender.org/D5542

Please tell me if I should rename variables and related functions in the source code too.

@Stephen Swaney (stiv): in video editing programs, the operation can be called splitting clips, and the tool that allows that is the razor tool. It's the case in Olive, and in Adobe Premiere at least, probably in other tools as well.

I always thought it was K for Knife, like the knife tool for performing this sort of operation in the rest of Blender. Would it make sense to call it Knife for consistency?