Page MenuHome

custom icons addons not showing
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GT 750M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-12.0.24 355.11.10.50.10.103

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
custom icons of addons don't load. they show blank

Exact steps for others to reproduce the error
Only on my Mac I have this problem. Windows, Linux no. Also they show in 2.81 branch (Mac). I currently have 2 addons that have the same behavior.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Hi @virgil sisoe (virgil89) : could you show us as small snippet how you are loading them into the PreviewCollection (how is the path you are passing into .load() constructed etc.)?
(this might give a hint when this changed)

That being said: if it is already fixed in 2.81, then this will be part of the next release (be it a 2.80a or 2.81...)

The add-ons are not made by me.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Archive this since fixed in 2.81...