Page MenuHome

Auto Perspective does not work with Align View to Active
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-8.1-6.3.9600 64 Bits
Graphics card: GeForce GT 730/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.71

Blender Version
Broken: version: 2.81 (sub 1), branch: master, commit date: 2019-08-08 20:54, hash: rB4c9fe657458f

Short description of error
When I rotate view from object orthographic (object top, left, etc. set with "Align View to Active"), view not switch to perspective as it would be with rotating from orthographic world top, left, etc.

Exact steps for others to reproduce the error

  1. Have Autoperspective enabled in setting
  2. Have view set to Perspective, not Orthographic
  3. Align view to active object (for example Shift+Numpad7). See that view goes to User Orthographic
  4. Rotate view with MMB. View still set to User Orthographic, not User Perspective.

Details

Type
Bug

Event Timeline

I don't find any problem to follow the previous steps reported on my system (Auto Perspective ON as default), linux Blender 2.80 f6cb5f54494e AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 435.17

The operating system, main memory size, GPU brand and model, GPU driver version and Blender hash or its build date may be needed by developers to investigate this issue

Update your GPU drivers from Nvidia support site can solve this problem

Thank You

Why should this have any connection with GPU driver? It's not a crash or anything like that.

I mean if my report is not a bug, but more like a suggestion, then you can close it.
But I think it's intuitive that autoperspective should work same way with object ortho views as it works with world ortho views

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Aug 20 2019, 2:59 PM

I can confirm the issue. Seems to be a bug, not sure why the current behavior should be intended.