Page MenuHome

"GPU failed to find function math_max" - related to eevee and material's blend_method setting
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.13.10-041310-generic-x86_64-with-debian-stretch-sid 64 Bits
Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.67

Blender Version
Broken: version: 2.81 (sub 2), branch: master, commit date: 2019-08-19 13:21, hash: rB45a09de9ddf2

Short description of error
GPU failed to find function math_max printed to terminal when going into lookdev/rendered shading with Eevee as the render. I'm pretty sure it's related to a material's blend method, as changing this setting will also print that error. At times the viewport seems to freeze for about 2 seconds or so.

Exact steps for others to reproduce the error

  • open the blend and switch to lookdev shading
  • if the terminal doesn't print the error message already, change the material's blend method

Event Timeline

MACHIN3 (MACHIN3) updated the task description. (Show Details)
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Aug 20 2019, 10:53 AM

Your drivers are over 1 year old, please update them and try again.

I can't do that right now. I did however confirm it on Windows, with the latest NVidia drivers.

rB74d05eb71a0d

renderer:	'Quadro P4000/PCIe/SSE2'
vendor:		'NVIDIA Corporation'
version:	'4.5.0 NVIDIA 431.02'

Please look into this, thanks.

Error reproduced using with the linked .blend :

ModuleNotFoundError: No module named 'generateAtlasGrid'
Read blend: C:\Users\Fin\Desktop\GPU_failed_to_find_function_math_max.blend
GPU failed to find function math_max

@Fin O'Riordan (fin.eskimo) Update your GPU drivers from Nvidia support site can solve/mitigate this problem

[EDIT] here work fine on linux Blender 2.80 f6cb5f54494e (Stable) AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 435.17, Factory Setting applied, Trusted Source disabled in file browser. work fine with LoadUI disabled and enabled on loading

It's confirmed here.

Windows 10
GTX 1070 - driver(430.86)

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Confirmed, Medium.Aug 21 2019, 11:44 AM

Assume this is confirmed (havent checked myself though)