Page MenuHome

Addons not showing in list
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: RTX 2080Fe

Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (optional)

After upgrading to the full release from beta versions of Blender 2.8 none of my addons will register for the full release. Even addons updated for the new release.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
Go to Prefs
Addons
Install

Addon.zip<

Install from file
search addon
Nothing.

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from 90 to 30.Aug 21 2019, 1:00 PM
Bastien Montagne (mont29) edited projects, added Add-ons, Import/Export; removed BF Blender.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

cannot reproduce, dont have issues installing zipped Addons in 2.80 or 2.81 master.

Tried e.g. https://github.com/SavMartin/TexTools-Blender/releases/download/TexTools_2.80/textools.zip

  • Do you get a message like Modules Installed () from '/some/path/textools.zip' into '/path/to/blender/2.80/scripts/addons'?
  • Are the zip contents properly installed there?
  • Does the folder in the zip contain a dot .? See this issue T65360
  • Do you get (error) messages regarding registration in the console?
  • if all this fails we probably need one of the offending Addons as a zip attached here to reproduce...
Bastien Montagne (mont29) changed the task status from Unknown Status to Invalid.Sep 2 2019, 7:09 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-05 17:27, hash: rBe993667a46c2
Also broken on 2.81, 2.80 and 2.79b
@Philipp Oeser (lichtwerk)

Do you get a message like Modules Installed () from '/some/path/textools.zip' into '/path/to/blender/2.80/scripts/addons'?

Yes.

Writing userprefs: 'C:\Users\Acrivec\AppData\Roaming\Blender Foundation\Blender\2.82\config\userpref.blend' ok
Modules Installed () from 'C:\\Users\\Acrivec\\Desktop\\luxcorerender-latest-win64-opencl.zip' into 'C:\\Users\\Acrivec\\AppData\\Roaming\\Blender Foundation\\Blender\\2.82\\scripts\\addons'

Are the zip contents properly installed there?

Yes.

Does the folder in the zip contain a dot .? See this issue T65360

No I believe. Also, it does look like on the video on T65360.

Do you get (error) messages regarding registration in the console?

I'd love to, but no.

I was having this problem when installing luxcore before, multiple times. Then, when I installed a zip of BlendLuxCore (which is standalone blender), it installed as a .zip properly. I also couldn't install openCL version, whereas normal version was installing fine.

I've removed every entity on my hard disk that contained expression 'lux' in order to be sure that no file was colliding. Ran blender as an admin. Nothing.
After clicking 'install' and selecting the zip, I can hear that CPU is doing some hard work for about 1.5 seconds.
On a proper install, as I remember, it should do that hard work for about 5 seconds.

That's the standalone zip file for luxcore

@Ray molenkamp (LazyDodo) wait, so I've been overwriting a proper addon installation with a standalone files and that actually was working for 2 months? O_O

Pardon me father, for have I sinned with stupidity of falling for the same mistake twice.

Well i can't say for sure what you have been doing, but what i do know for sure is that the zip you posted is the standalone one :)