Page MenuHome

Emulate 3 Buttons doesn't work with ALT Modifier key on UI buttons
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Quadro M6000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.02

Blender Version
Broken: version: 2.81 (sub 3), branch: master, commit date: 2019-08-21 20:48, hash: rB189aa32a3ac0
Worked: (optional)

Short description of error
Emulate 3 Buttons doesn't work with ALT Modifier key on UI buttons

Exact steps for others to reproduce the error
When we add modifiers keys to a button on pie menus or UI buttons, Emulate 3 Buttons doesn't work with the ALT key.

Example: This button allows several actions with modifiers keys.
ALT doesn't work with Emulate 3 Buttons.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

Well, obviously it doesn't, if you enabled Emulate 3 Button Mouse. Alt-click is interpreted as MMB click then.

It's not a bug, it's how Emulate 3 Button Mouse works.

Not on a button, it should not.
it's a simple click, it should not activate the panning but just click.

Sorry, but for me, it's a bug!

It breaks the system of modifier keys.

Emulate 3 Button Mouse has nothing specifically to do with panning. It is a feature meant for input devices without MMB. It maps Alt-LMB to be interpreted as MMB. That's the point of the feature, and that's how it works. So it's not a bug.

that's not right. When you open a pie menu the emulate does not have to work because it is in another context. however, you cannot use the alt option button to do a different action in the pie menu. For me we should be able to do it. It doesn't interfere with the functionality of the emulate.

+1 with jemian, ALT is a modifier key, Emulate 3 Buttons breaks modifiers keys system when it could work correctly.
I don't know if you know it or use it, it's really powerful and helps to keep clean UI.
It's not for the beginners for sure but, we need to keep it and improve it, make it work will all keymaps.

You can still keep the panning when pressing outside a button, I don't see the issue there.
Juste disables Emulate 3 Buttons when the cursor is on a button in the UI or a pie/menu.

Maybe it's not a bug because it doesn't interfere with Blender's functions but it does prevent us from using this option key for the pie menu buttons.The emulate shouldn't be active in this case.