Page MenuHome

Unable to view texture when UV editing
Closed, InvalidPublic

Description

Using 2.8 release.

I apologise that this is probably not a bug but some missing functionality but I want to check because it doesn't seem right at all and slows down workflows.

Stage 1: I model an object
Stage 2: I open the 'UV editor' and unwrap it, load up a texture to place UVs on.
Stage 3: In viewport shading options I select 'texture' to view the texture in the viewport but nothing appears.

To get Blender 2.8 to display this texture in the 'UV editing' viewport I have to exit, go into 'shading', create a dummy image texture node in shading window, select the texture. Then delete it and the dummy shader, then go back into UVs to continue with my model. Then the texture is visible in the viewport.

This seems like a bad workflow to have to go into shading before models are ready for lighting/shading. Is there a way to get textures visible in UV editing viewport without having to exit and create nodes in 'shading' and then going back to finish UVs?

Thanks,
Jonathan

Details

Type
Bug

Event Timeline

IMO, you forgot to assign material related to texture at modeled object, or you forgot to mention it in steps to follow to reproduce this bug

this screenshot is made on linux Blender 2.80 f6cb5f54494e (Stable) AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 435.17 with proper settings

However, you forgot to upload a simplest possible .blend file to reproduce this issue and fill relevant data as request in bug template

The operating system, main memory size, GPU brand and model, GPU driver version and Blender hash or its build date may be needed by developers to investigate this problem

Next time you want report a bug you can use Help > Report a Bug item and strictly compile following proposed form, all text from [ to ] must be edited. You must clearly describe steps to reproduce issue and attach a simplest possible .blend file as request.

Before making a new error report, the use of the 'Search' box (top right on the Error Reporting page) is very much appreciated to check if the errors / problems have already been reported by other users, every minute you dedicate this is a minute earned by the developer to fix bugs. The duplication of the bugreport is a waste of time and resources for the developers

Thank You

Abid Maqbool (cto.abid) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.EditedAug 28 2019, 5:26 AM

IMO, not a bugs though...
Note: For support consider https://blender.community/c/
let we know, you get what you want?

Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

We do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com and our devtalk should be used for that matter.