Page MenuHome

Bevel on mesh ( CTRL + B) not working as expected
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.81 (sub 3), branch: master, commit date: 2019-08-28 03:44, hash: rBf88022b96f3a
Worked: (optional)

Short description of error
When adding a bevel line on a object, it has strange behaviour. I tested this in the stable build and this latest release. To check if my geometry was build wrong i tested this in 2.79b and it worked well. The video shows what is wrong and what i like to do with the bevel

Exact steps for others to reproduce the error
https://www.youtube.com/watch?v=nfc1gASxo6Q&feature=youtu.be

Event Timeline

Abid Maqbool (cto.abid) lowered the priority of this task from 90 to 30.EditedAug 29 2019, 11:52 AM

@rob (blenderpedia) Please! Provide simplest possible file which will produce bug/error.
Normally Bevel edges Ctrl + B seems working fine...
e.g.


I isolated the object so you can see the behaviour.

@rob (blenderpedia) Hum! It's because, probably your mesh is too complex for poor Blender!!!
After Selecting whole Mesh (Ctrl + A) then applying Alt + N (Normals) -> Recalculate Outside Fix the issue...

Philipp Oeser (lichtwerk) changed the task status from Unknown Status to Invalid.Aug 29 2019, 2:02 PM
Philipp Oeser (lichtwerk) claimed this task.

Yes, what @Abid Maqbool (cto.abid) said: bevel depends on consistent normals.
Since this is behaving as expected (with consistent normals), will close as not-a-bug...
Thx for reporting anyways!