Page MenuHome

Blender 2.8 crash on Subdivision Surface modifier.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 7 64bit
Graphics card: NVidia 980GTX

Blender Version
Broken: 2.80, Downloaded 8/29/2019
Worked: (optional)

Short description of error
Blender crash on Subdivision Surface modifier when I try to add it on cylinder mesh with more than 300 vertices. This happens every time I did it, not just once.

Exact steps for others to reproduce the error
Just make new cylinder mesh, and enter for example 400 vertices in Cylinder properties. Then add Subdivision Surface modifier on it and try to make Viewport to 1 or 2. Blender crash every time on my computer.
I use Blender for a years and this same procedure work fine on Blender 2.79b.

Please help!
Dalibor

Details

Type
Bug

Event Timeline

Abid Maqbool (cto.abid) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Aug 29 2019, 2:54 PM

IMO, not looks like any bug/error here...
Rather a performance issue with Blender that currently Blender 2.8 is facing, especially Undo/Redo operation, Sub-Surface Modifier & Maybe Sculpting too
@Dalibor (Dasti) However, Please provide full system info:
Simply Edit your Report & follow template by Blender -> Help -> Report A Bug:


& Please Attach file generated by Help -> Save System Info
Thanks

Here is

Thanks for reporting. I can't reproduce this issue though. Blender doesn't crash but it takes a long time to add the modifier. Tested on mac.

Hi,
Problem still exist, but thanks anyway!
This works in Blender 2.79 with much, much more vertices perfectly, so I hope you will fix that soon.

Actually I need to report another bug also, if that's a bug actually.
In some of my projects made in Blender 2.79 when I open them in 2.8 and change Render Sampling Value in Cycles Render Settings, Blender keep to render in previous Sampling values. Whatever I put in Scene > Sampling > Render field, render will start with old value and keep it all the time.

Thanks!
Dalibor

Please:

  • Give us your exact Blender, OS and GPU (including drivers) versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker or open source ones in linux distributions).
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).

Also, how many RAM do you have on your machine? Could it be that Blender runs out of available memory?

Bastien Montagne (mont29) closed this task as Archived.Sep 16 2019, 9:49 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.