Page MenuHome

Unlink deletes mesh
Closed, ArchivedPublic

Description

System Information
Operating system:
Graphics card: GEFORCE

Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (optional)

version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: f6cb5f54494e, type:
build date: 2019-07-29, 09:44 AM

Short description of error

I have a blender mesh I have been creating which I have been trying to join mesh together . I have noticed that these mesh seemed linked when I unlink them one of the meshes disappears without reason and has been removed from blender in its entirety. I was trying to unlink this item as thought it was preventing me joining two mesh.

https://gyazo.com/3e982493fde02c7bf75dbfe6cab7219d

Exact steps for others to reproduce the error


Based on the default startup or an attached .blend file (as simple as possible).

Click two meshes as pictured https://gyazo.com/3e982493fde02c7bf75dbfe6cab7219d then right click and press unlink one of the items is removed .

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.
Videos and/or links to external sites etc. are not acceptable as bug report (they can be provided as additional information only).

I am attaching blend file for you to test only

I tried to unlink these items show in the image as I wanted to join the meshes in the same position that they are . There seemed no mechanism that I tried including Join , merge , duplicate that would allow one mesh to be copy and pasted into the first in its current position. Previously meshes could be easily joined by the Join command in Blender 2.79 . Is this being caused by this link problem which is deleteting one of the mesh. The mesh is not malformed as it was originally created by Mesh Converter. Therefore this cannot be put at the blame of the designer me. I have ever only experienced this type f problem in Blender 2.8. which it seems to hide command s that have to be located with F3. If there is this great expanse at the top of the screen showing unhelpful view buttons, why can these commands not be put on pull down menus, like every other app on the planet? There seems to be no reset pallet view view which the only way to resolve is to save and reimport your mesh without Load UI being checked. I hope this feed back helps.

Dennise Kitten (virtualkitten) changed the edit policy from "Custom Policy" to "Task Author".
Dennise Kitten (virtualkitten) updated the task description. (Show Details)
Dennise Kitten (virtualkitten) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Sat, Aug 31, 3:51 PM
Pinus added a subscriber: Pinus.EditedSat, Aug 31, 4:51 PM

Maybe I did not understand the problem correctly, but I can connect with your file the axis and the arm with ctrl + j
(join in object mode) and I can separate them in edit mode with p (separate by material) again from each other.
Tested with 2.81 from today.

Which "Unlink" option did you choose? (material or collection or ...?)
A short video would be helpful.

Join works also with 2.8 final.
Here my working join file:

Hi Pinus , Thank you for testingg. I have tried with the next two hidden and this still refuses to join for me . Would you suggest this is my blender installation can you provide links to your dowloads please and i will reinstall with 2.18 and 2.8 as you have and try that? The lin was straight forward to emulate you just select the two items in the object viewer click the mesh and choose unlink hope this helps one of the items usually the pin disapears.

Pinus added a comment.EditedSun, Sep 1, 8:30 PM

Blender 2.81 download: https://builder.blender.org/download/

Again from the beginning (in object-mode and with the 2.8 key-set):

  1. If you open your file lift09, then first press the alt+A key to deselect axis and arm.
  1. Select the axis and press the right-mouse-button and choose "set-origin" => origin to geometry (this is how the axis becomes the pivot point)
  1. Press shift+s and choose "cursor to selected"
  1. Select the arm and then the axis => now press ctrl+j and join the objects.
  1. Press r+x and move your mouse to rotate your arm ...

This works with all other objects in your file.

Do not use the command "Unlink" or "Link" which is completely different than "separate" or "join"
You only need join and separate in your file (unless you want to bind an object to an other as an parent, or other things)

To "un-join" (disconect) arm and axis => switch to edit-mode => press A-key to select the connected objects and press "p" key and choose separate by material - thats all....

Which OS do you use Mac, Windows, Linux ?

If my guide did not help, then please make a short video about your attempt with "unlink" so that we can see what you are doing

Bastien Montagne (mont29) lowered the priority of this task from Waiting for Developer to Reproduce to Needs Information from User.Mon, Sep 2, 4:39 PM

@Dennise Kitten (virtualkitten) And please do not triage bugs yourself, this is a task reserved to developers.

Bastien Montagne (mont29) closed this task as Archived.Mon, Sep 9, 8:28 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.