Page MenuHome

Surface Deform Modifier is Not Binding or Updating
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce RTX 2080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.35

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
For a Marvelous Designer + Blender Workflow to stay out of Maya, set up shape keys for a flat version of the garment so it deforms to the
wrapped version of the garment. When trying to bind the retopologized version, done in blender, nothing appears to happen.
Bind doesn't show unbind notifying me if anything happened, neither does the screen so I'm unsure if I'm doing something wrong or if
this functionality that is needed for this just is not working for some reason.

Exact steps for others to reproduce the error

  1. Check NovaClothes Flat shape key and turn value to 1 to see if it is functioning.
  2. Either bind the Plane to NovaClothes Flat at 16 Interpolation falloff, alternatively delete modfier and create one targeting NovaClothesFlat with 16

falloff.

  1. Hit the bind on the modifier, and see how it doesn't become unbind.
  2. Click onto NovaClothesFlat using any method while in object mode
  3. Set shape key value of NovaClothesFlat to 1 for NovaClothes.002
  4. See no change in the Plane and that the surface deform modifier appears to have no affect.

Details

Type
Bug

Related Objects

Event Timeline

Just check file... Blender 2.81 (sub 4) 2019-08-30 19:33 rB6726e98fe2a6

When Clicking Bind:

got error:

ERROR (bke.modifier): c:\b\win64_cmake_vs2017\win64_cmake_vs2017\blender.git\source\blender\blenkernel\intern\modifier.c:410 modifier_setError: Target contains concave polygons

Latter checking... Thanks

Abid Maqbool (cto.abid) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Aug 31 2019, 9:34 AM

IMO, not a bug!
It's how Surface Deform Modifier works (target must be not concave)

Here, is an example:

  • On Left Side, Same Object with correct faces(concave) (I can apply Surface Deform Modifier -> Bind)
  • On Right Side Same Object with concave faces I get exact same error.


Maybe can help you: https://www.youtube.com/watch?v=QjzBndN5ayA

You can solve it, manually/automatically:
https://docs.blender.org/manual/en/latest/modeling/meshes/editing/cleanup.html#split-concave-faces

@Amaan T Redmond (GlaiveSin) Let we know, you resolved it?
Thanks! Have a nice day!!!

Hello Abid,

Thank you very much for clarifying, it was infact user error. I didn't realize that the Target Mesh with the shape keys needed to not have non-manifold topology and after fixing this. I got the objects to deform Thank you very much.
I'll mention the great support from blender and you specifically when the game comes out and if anyone asks who has helped.

Sincerely,
Average Blender User.

Status Closed.

Abid Maqbool (cto.abid) closed this task as Invalid.Aug 31 2019, 5:30 PM
Abid Maqbool (cto.abid) claimed this task.

Thanks for reporting back!