Page MenuHome

blender keeps crashing on GPU render
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.70

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
[whenever I try to render using GPU, the rendering starts but halfway through the render the blender just shuts down without any warning,. However, when I use CPU rendering everything works just fine]

Exact steps for others to reproduce the error
[Change the rendering from CPU to GPU rendering put animation on render and halfway through the blender crashes]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

You mean half way the frame, or half way the animation?

If it's the second, what are you rendering? because if you are rendering something with animation nodes, flip fluids or some similar addon, it has random crashes because of an unsolved bug.

it sometimes happen halfway through the frame otherwise sometimes 6-7 frames render and then the blender crashes. I have to put it on render like 2-3 times every hour coz it blender keeps on crashing

also the only ADD ON I have enabled is node wrangler @Juan Gea (juang3d)

Pinus added a subscriber: Pinus.EditedAug 31 2019, 1:18 PM

@Kumar (harsh)
If you can render with the CPU, but not with the GPU, then your GPU may not have enough RAM.
It may also be that your system (PC) does not have enough RAM, or not enough free hard drive space ...
check this please ...

It can also be a thermal problem of your GPU = lack of cooling ...

I had a similar problem and reinstalling and updating my GPU Geforce drivers solved the issue with 2.8 I had .Hope this helps D

@Pinus The rendering starts if I am using the GPU. the blocks start rendering then after rendering like half the frame it crashes.

Pinus added a comment.EditedAug 31 2019, 5:37 PM

@ harsh
Could you fix the problem? ( and how?)
If the problem still exists after a driver update, then you should upload your file and the result of blender_debug_log.cmd+blender_debug_gpu.cmd as well as your system info file
(blender menu (top left) => help => save system ...)

Please test this first with 2.81 from today and report.

I cant upload the file but yeah updating the driver did help. it still crashes but just not as frequently. @Pinus I will test this with blender 2.81

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Jan 3 2020, 2:54 PM

@ harsh
Could you fix the problem? ( and how?)
If the problem still exists after a driver update, then you should upload your file and the result of blender_debug_log.cmd+blender_debug_gpu.cmd as well as your system info file
(blender menu (top left) => help => save system ...)
Please test this first with 2.81 from today and report.

Hi again, sorry this has been lying around for so long...
Is this still happening for you?
If yes, it would be really good to have an example file where this happens [you can try to strip down your file or try to recreate in a fresh file], without an example, I am afraid there is not much we can do...
(except the result of blender_debug_log.cmd+blender_debug_gpu.cmd as well as your system info file as @Pinus wrote)

Dalai Felinto (dfelinto) claimed this task.

No activity for more than a week. As per the tracker policy we assume the issue is gone and can be closed.
Thanks again for the report

If the problem persists we can exceptionally re-open this file (poke developers here or on blender.chat to re-open it).
We are going through a tracker cleansing so trying to close old reports as much as we can.