Page MenuHome

Cannot edit a curve
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
When I activate this triangle curve and enter edit mode, it will disappear and I cannot edit it (e.g. select some spline points).

Exact steps for others to reproduce the error
Please activate a triangle curve of this attached .blend file and enter edit mode.


Details

Type
Bug

Event Timeline

Abid Maqbool (cto.abid) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.EditedAug 31 2019, 5:47 PM

IMHO, Not a bug/error!
@Naoki Mochizuki (tamaki_py) I think, no need to enter Edit Mode you should edit shape in Object Mode

Some object are hidden, activate them all in Outliner:

(Shift + Double Click)

You can move circular object in object mode to edit shape

Let we know, thanks!!!

This comment was removed by dark999 (dark999).

Thank you for your reply, Abid.

It is certainly true that I hooked these spline points of the triangle curve to circular objects.
So we can change the shape of the triagnle by moving them.
But I still have a problem.

Here, I attached an additional .blend file which enable us to compare two triangle curves whose spline points are hooked to circular objects.
One cannot be edited but the other can be edited (e.g. select some spline points and move them).
This phenomenon happens unexpectedly, so I cannot predict when it will happen.
What is the difference between these two ?



I'm sorry for my poor explanation.

@Naoki Mochizuki (tamaki_py) Hum! That's was pretty interesting q!
It's because, in Edit Mode, triangle is already scale of 0, so it's looks like a point.
You can select Point-by-Point and try to drag...e.g.


Hope, it's helps you..
Thanks!

Your suggestion resolves my problem, thank you !

Abid Maqbool (cto.abid) closed this task as Invalid.Sep 1 2019, 11:25 AM
Abid Maqbool (cto.abid) claimed this task.

Thanks! For reporting back. Glad it solves you!!!