Page MenuHome

Hair particles: 'Use modifier Stack' option removes all hair if particles have been added or removed in particle editmode
Confirmed, NormalPublicKNOWN ISSUE

Description

System Information
Operating system: Linux-3.10.0-957.10.1.el7.x86_64-x86_64-with-centos-7.6.1810-Core 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.56

Blender Version
Broken: version: 2.81 (sub 4), branch: master, commit date: 2019-09-02 15:37, hash: rB283d96de1170

Short description of error
Use modifier stack checkbox deletes all the hair particles if they were created with the add hair brush and combed (not necessary), even if there are no modifiers before the particle system. This also happens if particles have been deleted (X) in particle editmode.
And there is no way to get those hairs back. It can really destroy all your work on grooming.
By the way, that check box becomes inactive in 2.79 after grooming, but it's active for some reason.

Exact steps for others to reproduce the error
Create a hair particle system.
Go into particle edit mode.
Delete all the hairs (by the way, you won't be able to do that until you comb it, may be a second bug).
Add some hairs via add hair brush (you can add hair without deleting on the previous step, the bug will occur anyway).
Go back to object mode.
Check the use modifier stack checkbox.
All the hairs disappear!

The attached file has all that done except the very last step.

Event Timeline

Yegor (Yegor) updated the task description. (Show Details)Sep 3 2019, 6:56 PM
Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 50.Sep 4 2019, 8:29 AM

By the way, that check box becomes inactive in 2.79 after grooming, but it's active for some reason.

The whole subpanel PARTICLE_PT_emission_source should not be active when PARTICLE_PT_emission (parent panel_id) isnt.

Philipp Oeser (lichtwerk) renamed this task from Use modifier stack checkbox vanishes all the hair particles to Hair particles: 'Use modifier Stack' option removes all hair if particles have been added or removed in particle editmode.Sep 4 2019, 10:36 AM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)

by the way, you won't be able to do that until you comb it, may be a second bug

confirmed as well [it might be better to open a separate report on this]

by the way, you won't be able to do that until you comb it, may be a second bug

confirmed as well [it might be better to open a separate report on this]

This has now been reported in T69487

Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Known Issue".

Sadly, will have to tag as "Known Issue" now, since hair will be ported to a new hair object type anyways, so this will likely not be touched...

Dealing with the same issue now, hopefully it will be resolved with new hair system =((