Page MenuHome

Blender crash when trying to open a file window on Linux/Intel
Open, Confirmed, HighPublic

Description

System Information
Operating system: Linux-4.15.0-58-generic-x86_64-with-Ubuntu-18.04-bionic 64 Bits
Graphics card: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) Intel Open Source Technology Center 4.5 (Core Profile) Mesa 19.0.8

Blender Version
Broken: version: 2.81 (sub 5), branch: master, commit date: 2019-09-03 20:34, hash: rB5ba0ce854410
Worked: (optional)

Short description of error
Blender closes when trying to open a file, with this message:

blender: src/intel/genxml/gen8_pack.h:72: __gen_uint: Assertion `v <= max' failed.
Aborted (core dumped)

Details

Type
Bug

Event Timeline

ehhhh ... I searched the bug tracker few times for the crash keyword and did not find your report or any other report related to this error, as soon as I added my report I suddenly see your bug report :P

This does seem like a GPU driver issue, we already had one in T69483.

Please try if it works when starting Blender through the blender-softwaregl script bundled with release/buildbot builds.
If this affects many users we should probably look into a workaround, although this will be difficult to do with no way to recreate it.

Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 4 2019, 7:21 PM
Piotr Kudzin (sng84) added a comment.EditedSep 4 2019, 7:24 PM

blender-softwaregl works for me (it does save), but then blender is to slow to use it for modeling

Julian Eisel (Severin) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Sep 4 2019, 7:45 PM

That means it is indeed a GPU driver issue. (The scripts make graphics work run on the CPU rather than the GPU, bypassing the driver. It's only usable for testing.)
Interestingly all three reports are with Mesa 19.0.8. You can try installing newer versions, https://mesa3d.org/.

Not sure what to do with the report, technically it's not a bug on our side. But this seems to affect a number of people, so we better find a workaround.
Maybe I can try to get 19.0.8 installed to see if I can recreate it then.

glxinfo | grep "OpenGL version"
OpenGL version string: 3.3 (Compatibility Profile) Mesa 19.1.4

Works OK

@Piotr Kudzin (sng84) @Julian Eisel (Severin)
Running Blender through that script doesn't do much, and yeah it's apparent that the bug is on GPU side.
Unfortunately I can't risk my system stability by updating GPU's driver from other repository other than System repository.
I will wait for a workaround or until Ubuntu release Mesa update.
Thanks for your reply

@mohamed (mohamed) El Hamd (elbox01)

There is mesa ppa repository prepared by Canonical, which i used for upgrade.

http://ubuntuhandbook.org/index.php/2019/08/mesa-19-1-4-available-to-install-in-ubuntu-18-04-19-04/

There are given steps for easy install and easy uninstall (if something goes wrong) - just few commands

my computer has not yet exploded ;)

Haha ... @Piotr Kudzin (sng84) Thank you for the hint, I didn't know about that repo .
Now, everything works as expected :)

Julian Eisel (Severin) closed this task as Archived.Sep 9 2019, 11:10 AM
Julian Eisel (Severin) claimed this task.

Okay so we haven't gotten any new reports on this and the issue is fixed with updated drivers. So it's probably not worth doing workarounds from our side. I'll close this now, but surely look out for similar reports.

Brecht Van Lommel (brecht) lowered the priority of this task from Waiting for Developer to Reproduce to Confirmed, High.

We can't assume our user are running the very latest drivers on Linux. Running Blender on common Linux distributions should not require installing custom drivers to be able to open files.

Hi folks

Thanks for your efforts. Really appreciated as it seems my only way forward with 2.81 and beyond would be a new laptop that I cqn't really afford at the moment. So two things:

Had a scout around for a way to update Mesa on my system - nothing found.
Also just to make it clear - 2.81 was working fine. It started crashing with the new file browser.

Anything you need in the way of testing just let me know.

Thanks
Jeff

Had a scout around for a way to update Mesa on my system - nothing found.

You need mesa >=19.1.1 to fix the AMD driver context switch bug:
https://developer.blender.org/T61093#716608

Edit: sorry missed that this is about the Intel driver :-/

In case you miss it on the other page - Thankyou Martin, it worked fine. Really appreciated.

Currently not able to reproduce it to see what the actual issue is. Will need to find a specific machine where it fails. According to the specs my home machine would have failed, but didn't

Recently I received an update of Mesa and the issue seems to be fixed. Now, I cannot reproduce it, either.
Tested it on both versions e2df789c4800, where the issue occurred, as well as with the latest build 5a6ab6f59468.
Curiously Mesa still reports 19.0.8. Better version tracking by the distributor would be desirable...

RT (Stillpointx) added a comment.EditedSep 25 2019, 1:32 AM

I also received several software updates from Ubuntu / Canonical updating Mesa and can now open blend files. I used version
blender-2.81-52bdf522afcd-linux-glibc217-x86_64. Note: I did not install the custom Mesa drivers from the PPA

The Mesa version does still report 19.0.8

The Mesa version does still report 19.0.8

You can ask the packet manager. On debian based systems:

dpkg -l | grep mesa
ii  libegl-mesa0:amd64                                          1:19.2~git190714221300.4e102a6~b~padoka0                    amd64        free implementation of the EGL API -- Mesa vendor library
…

or try glxinfo | grep Mesa

Ubuntu could have backported some fixes.

I just wanted to come back to the comment of Martin Capitanio. Running glxinfo doesn't give more information as we already know. The dpkg command indeed showed that there was a change in package version, though it is not a very convenient solution, since one has to know the faulty package name for each Linux Distribution and for each of its supported Versions ...

Probably this issue should be closed. You can only document the problem and recommend affected users to update their system.