Page MenuHome

Mocap Tools update 2.81
Open, NormalPublic


hi, this is the task for the mocap tools update to 2.81 as provided by @Osamu Takasugi (SAMtak) in D5606
First thing I notice is the _PT_ _MT_ _OT_ could be improved on. MCT_OT_classname would be a good naming convention here. The old way was right in the use of OBJECT_OT_classname, It's cleaned up too much possibly. use MCT_OT_ MCT_PT_ MCT_MT_ would be better I think.
I would like some files so if you could zip up the working addon and provide it here more people will have access without manually applying the patch.
@Osamu Takasugi (SAMtak) are you prepared to maintain this addon through the 2.8 series and help with future bugs and requests?



Event Timeline

Brendon Murphy (meta-androcto) triaged this task as Needs Information from User priority.Fri, Sep 6, 1:41 AM

hi, seems like this is a useful and needed addon, I'm concerned about maintenance.
@Osamu Takasugi (SAMtak) were you prepared to maintain the addon? Any other takers?

I'm interested mocap addon for a while, I may undertake maintenance If no other person take.

Brendon Murphy (meta-androcto) raised the priority of this task from Needs Information from User to Normal.Fri, Sep 20, 3:12 AM

hi @Osamu Takasugi (SAMtak) that would be great, I've committed your patch, I left in the panels closed by default as it's better for the ui space.
I also noted the changes to all the class names. This is not optimal atm. Convention was better in the original.
I would suggest using MOCAP_PT_ for the panels and MOCAP_OT_ for the operators and remove the operator extension at the end. This fits in better with our naming conventions we are trying to encourage.
If you make the changes you can upload a fixed files in zip and I'll check here locally.

Brendon Murphy (meta-androcto) renamed this task from Mocap Tools update 2.81 D5606 to Mocap Tools update 2.81.Fri, Sep 20, 3:13 AM