Page MenuHome

First selected object in Outliner is active one, while it is the last selected one that becomes active in 3DView
Closed, InvalidPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.02

Blender Version
Broken: version: 2.81 (sub 5), branch: master, commit date: 2019-09-03 16:04, hash: rBb3b59e3b5657
Worked: (optional)

Short description of error
The parenting behavior is backwards in the outliner. When parenting objects in the outliner, the active object becomes the child instead of the parent.

Exact steps for others to reproduce the error

Create two objects and attempt to create a parent relationship using CTRL+P

[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Fouad Hafiz (foodi) renamed this task from Parneting behaviour is backwards in the outliner to Parenting behaviour is backwards in the outliner.Sep 4 2019, 9:52 PM
Fouad Hafiz (foodi) created this task.
Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 30.Sep 5 2019, 12:00 PM

Not sure how you do this, afaict, there is no CTRL+P in the outliner...

Do you have this shortcut with Factory Settings as well?
Or did you add this yourself?
Which keyconfig are you using?

Fouad Hafiz (foodi) added a comment.EditedSep 5 2019, 7:00 PM

You're correct, you can't do CTRL+P in the outliner. I'm using default key config.

This was my sequence of events:

Make the selections in the outliner: select the child object, followed by the parent object, while holding down SHIFT.
Move the mouse cursor back to the 3D View, and hit CTRL+P>Object(Keep Transform)
The parent relationship is created, except it's backwards. The object selected first becomes the parent, instead of the child as you would expect.

@William Reynish (billreynish) @Nathan Craddock (Zachman) @Julian Eisel (Severin) Indeed in the outliner, the first selected object will be active one, while in 3DView it's always the last selected one that becomes active… Not sure whether we want to change that behavior or not?

Bastien Montagne (mont29) renamed this task from Parenting behaviour is backwards in the outliner to First selected object in Outliner is active one, while it is the last selected one that becomes active in 3DView.Sep 16 2019, 10:05 PM
Bastien Montagne (mont29) raised the priority of this task from 30 to Normal.

@Bastien Montagne (mont29) I guess we should make it consistent. It only really makes sense to parent the selected items to the active one I think.

@William Reynish (billreynish) parenting is totally unrelated to the issue here really… It just reveals the inconsistency in selection order (which confuses users):

  • If you select multiple objects from the Outliner, the first selected one is the active one.
  • If you select multiple objects from the 3DView, the last selected one is the active one.

@Bastien Montagne (mont29) ah yes. @Nathan Craddock (Zachman) is working on exactly that, also so that walk selecting can change the active item. It required refactoring selecting vs activation.

I discussed this report earlier today with the author (he messaged me on Twitter). The real issue was the use of Shift+LMB for selection in the outliner. Shift is the modifier key for doing a range select. When there is an active outliner element, range select will not activate any elements. Ctrl is the modifier for extending selection + activation (equivalent to Shift click in 3D view).

So selecting in the outliner Cube.001 then Cube.002 with a Ctrl+click would indeed make the second selection (Cube.002) active.

Jeroen Bakker (jbakker) closed this task as Invalid.Feb 4 2020, 11:22 AM
Jeroen Bakker (jbakker) claimed this task.
Jeroen Bakker (jbakker) changed the subtype of this task from "Report" to "Known Issue".

Seems to work as expected. There is an inconsistency between CTRL and Shift but that is done by design.