Page MenuHome

Tag or clear 2.81 Milestone Tasks
Open, NormalPublic

Description

Very Important Medium and Paper Cuts Tasks
Candidates for 2.81

This is a list of all the tasks marked as red that are not long term. We need to check with the module owners and developers if they are still targeted otherwise we change their priority. For the ones confirmed to be worked on we can then tag them with the Blender 2.81 Milestone.

UI

Modeling

Sculpt, Paint, Texture

Animation

EEVEE & Viewport

Render & Cycles

Data, Assets & I/O

VSE

Motion Tracking

Platforms, Builds & Tests

Note to self/Nathan, if we integrate our red/green/yellow/medium term/long term/... in the task status lists like these could be generated automatically.

Details

Type
To Do

Event Timeline

Dalai Felinto (dfelinto) renamed this task from 2.81 tasks to Tag or clear 2.81 Milestone Tasks.Thu, Sep 5, 5:32 PM
Dalai Felinto (dfelinto) closed this task as Resolved.Thu, Sep 5, 8:55 PM
Dalai Felinto (dfelinto) claimed this task.

Alright, everything properly tagged (with few exceptions). Closing now

Philipp Oeser (lichtwerk) reopened this task as Open.

I still dont see any bugs tagged for this milestone.
Not even the High Priority regression ones.
https://developer.blender.org/maniphest/project/2/type/Bug/query/1BLyvlG786dk/#R

Could these be considered as well please?

I think they should be considered as well, but for 2.81 the most important is to get started with 'new stuff'.

I suggest those who can and know what needs to get in tag bugs accordingly. Better safe than sorry, so check with devs, Dalai and me when it is not obvious a bug should be worked on for 2.81.

We have previously been using high priority bugs as meaning "must be fixed before next release". So to me it makes sense to just tag all those with the Blender 2.81 milestone.

I think @Philipp Oeser (lichtwerk) can just tag such bugs with the milestone if he considers them necessary to fix for Blender 2.81, and CC the relevant developers. It's better to over-tag and remove the tag later than for things to slip through.

I've gone ahead and tagged them all (the High Priority ones). More or less blindly as the priority decission has been made by core devs, so no use to mix in my own priority here again I think...
I might even add more High Priority ones the comming days (the more I go over - older - confirmed bugs, the more [pretty bad] regressions from 2.79 I find...)

+++ however, a couple of things to note: +++

  • once a bug is tagged with a milestone, you cannot find it anymore when you choose "Browse Bugs" from the phabricator homepage (because that will go to Maniphest > BF Blender > Bug > Open Tasks -- BF Blender is the culprit here)
  • you have to choose Manifest from the homepage instead... and edit your query for bugs there...
  • maybe we can alter the "Browse Bugs" link accordingly? (to not hide the bugs in a milestone)
  • also milestones seem to be hidden from https://developer.blender.org/project/ by default (you have to do Edit Query and change Hide Milestones)
  • there are also High Priority TODOs... not sure what to do with these (will leave them alone) e.g. T57936: Performance regressions

but for 2.81 the most important is to get started with 'new stuff'

I totally enjoy the 'new stuff' as well and we can probably afford to ride this wave a bit more, I am just a bit worried we might also loose a bit of reputation if we leave broken stuff alone for too long...

I am just a bit worried we might also loose a bit of reputation if we leave broken stuff alone for too long...

I meant using the new tagging mechanism. Not that we'd leave stuff out (: Obviously we should take care to fix as much as we can!

As @Brecht Van Lommel (brecht) says better overtag now and move to 2.82 later.

Good points about visibility, we can adapt the necessary pages for that.