Page MenuHome

Eyedropper is not colormanaged hence gives incorrect result and useless
Closed, InvalidPublic

Description

System Information
Operating system: Linux-3.10.0-957.10.1.el7.x86_64-x86_64-with-centos-7.6.1810-Core 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.56

Blender Version
Broken: version: 2.81 (sub 8), branch: master, commit date: 2019-09-05 10:52, hash: rBb6e7e173ecd9

Short description of error
The eyedropper gives incorrect color sample on picking from viewport or image viewer.
What's the point of eyedropper while shading, if you get a different color from what you see?
Since the feature is broken, I consider it a bug, not a feature request.

Exact steps for others to reproduce the error
Open the file attached.
The left image is a snapshot of the render from the right.
The bottom node is for sampling
Eyedrop from the render view or from the image and you'll get a different color from what you have in the top node.

Details

Type
Bug

Event Timeline

It visually appears to be working to my eyes.

The top RBG node is just the orange color that you have plugged into the Emission slot of the Principled BSDF. Because you are using the Principled BSDF shader, the plane also has:

  • a white diffuse surface
  • that is being lit by a white light. The white light is to the right of the plane, aligned with the top edge, causing a gradient that is brightest on the top right and darkest on the bottom left.
  • The diffuse surface has a roughness of 0.5 so that white light is not all reflected evenly. This causes the variance of gradient color when examining the values on a per pixel basis I believe.

These four things combine to give the plane the color you see in the rendered view.

If you turn off the light or just use an emission shader, the color picker matches the top RGB node visually. It is only slightly different when you examine the individual values.

When rendering out your setup (principled with the light on), the emission pass is identical to the top RBG node.

Below I have attached my augmented version of your file. Just load it and hit F12 to render.

Does this make sense/fix your issue?

Evan Wilson (EAW) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 5 2019, 9:43 PM

Oh, you are right! That was my mistake. Close that.

Julien DUROURE (julien) closed this task as Invalid.Sep 6 2019, 9:58 AM
Julien DUROURE (julien) claimed this task.