Page MenuHome

crash in BKE_scene_update_sound for a soundstrip without linked sound
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.16299 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.70

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]
Press Ctrl-A and selected "add text" and the program crashes. Tried it twice with this file. Same result both times.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
Press Ctrl-A, clicked "add text." crash.
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce this here (in both 2.80 and current master).

  • By Ctrl-A I assume you mean Shift+A?
  • Does this happen when you File > Defaults > Load Factory Settings prior as well?
  • Does this happen in a fresh build from https://builder.blender.org/download/

My apologies. Yes, it is Shift-A. I downloaded the latest build of 2.81 alpha just now, opened it, imported the file mentioned above. Did the Shift-A, clicked on "text" and it immediately crashed. A fresh file doesn't crash, and doesn't crash with any other file I have, so it's a mystery what might be different in this file.

imported the file mentioned above

cannot see a file mentioned here, mind uploading it?

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Confirmed, Medium.Wed, Sep 11, 5:28 PM

Can confirm (in this particular scene).
There is a soundstrip in the Video Sequence Editor that doesnt actually have a linked sound, and that will make BKE_sound_get_length crash (this is also called on dependency graph update when you add something to the scene)...
If you remove the (broken?) sound strip from the Video Sequence Editor, you should be fine... but fix is also incoming...

Philipp Oeser (lichtwerk) renamed this task from adding text crash to crash in BKE_scene_update_sound for a soundstrip without linked sound.

Hi. Yes, deleting the audio track takes care of the crash issue on 2.81 alpha. Thank you.

In tomorrows build (with the fix above), having the soundstip in there should also not crash anymore...