Page MenuHome

Smooth brush freezes on highpoly mesh
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: Radeon RX 560 Series ATI Technologies Inc. 4.5.13558 Core Profile Context 26.20.11015.5009

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: 2.79

Short description of error
Smooth brush freezes on highpoly mesh

Exact steps for others to reproduce the error
Smooth brush freezes in sculpting mode when working with models from 4...8 million triangles. The lag happens at the beginning of the use of the brush for a few seconds, then the brush is working fine. In the version 2.79 brush works fine with any number of polygons.
Addition: In version 2.79, this problem is also there, but only when you first use the brush, all subsequent times there is no freezing. Probably, the more powerful the computer, the more polygons it takes for this problem to make itself felt.
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Igor (unumex) updated the task description. (Show Details)
Igor (unumex) renamed this task from Fix Smooth Brush to Smooth brush freezes on highpoly mesh.
Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

We require an example .blend file that works fast in 2.79 but is slow in 2.80.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Tue, Sep 17, 5:36 PM