Page MenuHome

Pitch change does not update waveform or length
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10, 64 bit
Graphics card: Intel HD graphics

Blender Version
Broken: 2.80

Short description of error
When I change the pitch (really the speed) of an audio clip in the sequencer, neither the waveform display or the length of the clip updates. If the clip is used all the way to the end, the end is lost at a lower pitch. Don't know what happens with higher pitch.

Exact steps for others to reproduce the error
Create video editing file.
Add an audio strip.
Adjust frame end if neccesary so whole clip can be played.
Change the pitch to 0.5 and enable waveform drawing.
The waveform will still be at the original speed, and the end half of the clip will be missing. Trying to pull the end tab out won't work either.

Details

Type
Bug

Related Objects

Event Timeline

Richard Antalik (ISS) closed this task as Archived.
Richard Antalik (ISS) claimed this task.

Unfortunately we are unable to solve this issue immediately.
Since this will require redesign of quite lot of sequencer code, I would see this in 2.82 if I was optimistic.

Closing this, since it's covered by module TODO T59540: VSE timeline manipulation API