Page MenuHome

Bezier Curve geometry gets distorted by object scaling
Closed, InvalidPublic

Description

System Information
Operating system: Linux-5.0.0-27-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GT 730/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.56

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e

Short description of error
Scaling a curve in object mode affects bevel and extrude paramaters. Applying scale does not help to restore them.

Exact steps for others to reproduce the error

  1. create a default curve
  2. set up curve bevel as 0.1m -- thickness of curve becomes 0.2m
  3. scale the curve in object mode twice -- thickness becomes 0.4m
  4. apply scale -- thickness remains 0.4m

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

This is expected behavior.
If you scale the curve in editmode, then the curve geometry resulting from the bevel depth will get generated from the 'scaled' curve data (after scaling).
If you do this in objectmode, then the curve geometry resulting from the bevel depth will get generated from the original curve data (prior to scaling -- and everything will get scaled by the object transform afterwards).

Thx for the report, but will close as not-a-bug.

If I do it in object mode with mesh, I can later "apply transform", it resets object scale to 1 and internal parameters (such as skin or edges bevel) will be recalculated. For curves this does not work.

The only way to fix bevel after applying transform is using measuring tools and calculations. I doubt it was intended.

The correction of this behavior was made in the standard addon: add_curve_extra_objects. Turn it on and the "Scale Reset" item will appear on the context menu.