Page MenuHome

Face Orientation not visible when material's viewport display uses alpha
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
The Face Orientation viewport overlay does not work on an object which has a material applied that uses an alpha value lower than 1 in its Viewport Display settings. If the object has multiple materials applied the overlay will only work on faces that have a material applied which doesn't use transparency in the viewport.

Thank you.

Details

Type
Bug

Event Timeline

Can you provide a simple file to make it easier to investigate this problem?

i try to reproduce this problem, with this file


the only mode i find to reproduce your problem is download mine test file and set X-Ray value to 1 in Viewport Shading popover, mesh is show ed with material instead faces orientation
i test on linux Blender 2.80 f6cb5f54494e (Stable) AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 435.21, Factory Setting applied, same on

@Tom Truyens (TomT) maybe update your ancient GPU drivers from Nvidia support site can solve/mitigate others possible problem

Thank You

Germano Cavalcante (mano-wii) triaged this task as Confirmed, Medium priority.Mon, Sep 16, 10:03 PM