Page MenuHome

UI Consistency - Cancel button missing for baking / generating point caches
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.2.13-zen1-1-zen-x86_64-with-arch-Arch-Linux 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken: version: 2.81 (sub 10), branch: master, commit date: 2019-09-11 18:58, hash: rB9a076dd95a01
Worked: (optional)

Short description of error
Progress bar for e.g. generating point caches is missing a cancel button / cancel UI element but can be canceled via ESC.

Exact steps for others to reproduce the error

  • Render a scene

-> Note the progress bar with cancel button X in the statusbar.

  • Bake dynamic paint

-> Note the progress bar without a cancel button in the statusbar, baking process can be canceled via ESC nonetheless.

Solution:
Add a cancel button similar to the one used in the render progress bar.

Examples:
Please see https://devtalk.blender.org/t/blender-ui-paper-cuts/2596/3183?u=berg

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

For user feedback and feature requests, please use other channels than the bug tracker:
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests

Hello Brecht,
thanks for the response on this issue. I like to try to challenge the decicion to close it, because of the following reasons:

  • The render progress bar has a (reference) implementation the UI team agreed upon on how to display the status of an action in the status bar.
  • It has two user interaction points: view (progress), interaction (cancel)
  • For cancel there are two ways implemented: via UI (cancel Button) via Shortcut (ESC)

Now we have serval places where that implementation is used in blender.
One of them is the baking progress bar. It has the same functionalities as mentioned above (view (progress), interaction (cancel)), but is missing the visual cancel button.

  • So we have a proven design, therefore no further concept/mockup needed.
  • It‘s actionable.
  • It‘s not a bug, but maybe we can add it to a different tasks (papercuts?), UI tasks...instead of closing it ;)

Thanks and take care,
Stephan