Page MenuHome

Laggy interface with highpoly sculpt and dyntopo
Closed, InvalidPublic

Description

System Information
Operating system: Linux-5.0.0-27-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: AMD Radeon (TM) RX 460 Graphics (POLARIS11, DRM 3.31.0, 5.0.0-27-generic, LLVM 7.1.0) X.Org 4.5 (Core Profile) Mesa 18.3.0-rc4

Blender Version
Broken: version: 2.81 (sub 10), branch: master, commit date: 2019-09-10 22:12, hash: rB4ce3fbd52ae8
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]
Blender voxel remesher works after using it on a setting of 0.01. I then switch into dynotop and blender freezes up. I then try to terminate the blender process using ksysguard. Blender becomes zombie and my computer freezes up.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]
Join the mesh pieces using the join operation. After this switch into sculpt mode and voxel remesh the mesh using a setting of 0.01. Then switch into dynotop mode and change the brush size. Try to rotate the view so the joints can be fixed. It should freeze up when trying to rotate the view.

I've included an attachment of the mesh that has given me trouble.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Seems the file is missing...

I will try and upload the file again.

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

Looks like this is just to heavy on resolution on your machine (maybe also related to that particular GPU and mesa?).
With a remesh of 0.01you are already at a facecount of ~4mill, turning on dyntopo on top will also lead to lags here (especially on the first viewport rotation, subsequent rotations are much smoother -- but certainly does not lead to a complete freeze), I am on linux with a 970m.

Would not consider this a bug, it is not related to the voxel remesher (same thing happens with just a subidivied cube at ~5mill faces).
Will close this as not-a-bug, but feel free to comment again if you still think you've found a bug...

Philipp Oeser (lichtwerk) renamed this task from Voxel remesher then dynotop crash. to Laggy interface with highpoly sculpt and dyntopo.Thu, Sep 12, 11:49 AM