Page MenuHome

Crash when selecting/middle mouse multi mesh object
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.15

Blender Version
Broken: version: 2.81 (sub 10), branch: master, commit date: 2019-09-11 21:31, hash: rB1e375ab5a104

Short description of error
Getting a crash with a multi mesh object. Happens with either toggling selection or rotating view with mouse.

Exact steps for others to reproduce the error
1: Double press "A"
2: Press middle mouse
3: Keep repeating steps until a crash

or

1: In select menu select "None"
2: Press middle mouse

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here (linux, 970m, 430.26 drivers).
Is this also happening with Factory Defaults?

@Zachary (AFWS) :

  1. Can you reproduce from your attached file?
  2. Can you reproduce it from scratch (add objects, join them, ...)?

I cannot reproduce either (tried with the same hash as you) and I suspect the issue may be sanitized upon saving. But if that's the case need clear instructions on how to reproduce reliably.

Dalai Felinto (dfelinto) closed this task as Resolved.Thu, Sep 12, 3:41 PM
Dalai Felinto (dfelinto) claimed this task.

Assuming it is a dupli of T69785. We can reopen if user can still reproduce in latest Blender.

Zachary (AFWS) added a comment.EditedThu, Sep 12, 5:18 PM

@Dalai Felinto (dfelinto)

I was able to reproduce on just default cube after saving that file. I think it was T69785 causing it. Updated blender this morning after the fix and not having the issue anymore.