Page MenuHome

Denoising Albedo gives wrong results
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.15

Blender Version
Broken: version: 2.81 (sub 10), branch: master, commit date: 2019-09-09 20:20, hash: rB3e81c1c1d5fd

Short description of error
Denoising Albedo pass appears washed out

Exact steps for others to reproduce the error

Open the following blend file and press F12

The Denoising albedo pass will come out like this


Lower the Principled Roughness value to 0 and press F12 again

This time the albedo looks correct


Switching to Metallic 1.0 and Roughness 0.5 looks like the albedo is completely lost


For the denoiser to give proper results, the Denoiser Albedo pass would need to give clean colors, not washed out colors.

Details

Type
Bug

Event Timeline

Daniel Salazar (zanqdo) closed this task as Archived.Sep 12 2019, 2:15 AM
Daniel Salazar (zanqdo) updated the task description. (Show Details)

While it is true that the Denoising Albedo looks washed out, it does not seem to be an issue. Using the Denoise node with it works just fine. Or do you get any issue with the denoising?

@Stefan Werner (swerner) Can you give more information? Feel free to close this if it is not actually a bug.

Denoise is a complex feature meant for use in production files, you can't judge the results on a monkey head. The bug report is about the Albedo pass being incorrect, which clearly shows. Not about demonstrating it's effects on denoising. However I can provide an example of incorrect denoising extracted from a real scene.

Original (Noisy)

Denoised with Denoising Albedo (Incorrect result)

Denoised only with Subsurface Color pass (Correct result)

What is happening is that the correct albedo is already present in the Subsurface Color pass shown below

The Gloss color pass however gives a white result

When the 2 are added together in the Denoising Albedo pass the resulting pass is washed out hence being incorrect and useless for denoising

Blend file can be found here

Press F12 and wait for the render to finish.