Page MenuHome

Blender crashes at opening new windows
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Linux-5.2.14-arch1-1-ARCH-x86_64-with-arch 64 Bits
Graphics card: GeForce 8400GS/PCIe/SSE2 NVIDIA Corporation 3.3.0 NVIDIA 340.107

Blender Version
Broken: version: 2.81 (sub 8), branch: master, commit date: 2019-09-05 10:52, hash: rBb6e7e173ecd9

Short description of error
I've been experiencing some issues since the 2.80 landed this happens when opening a new window for eg. (user preferences, render view, and now the new file manager)
I opened the terminal to see the issue and it shows this:

X Error of failed request:  GLXBadDrawable
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  11 (X_GLXSwapBuffers)
  Serial number of failed request:  486064
  Current serial number in output stream:  48606

also in lookdev mode:

X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  79631
  Current serial number in output stream:  79631

Exact steps for others to reproduce the error
It won't happen as soon as I start blender, but it will always after a while, and then I have to restart blender. I think it's something related to hardware. I know I'm using outdated hardware.

Details

Type
Bug

Event Timeline

Pinus added a subscriber: Pinus.Sep 19 2019, 3:53 PM

@ Sebastian:
Your Graphic-Card is to old, with Blender 2.8 the minimum requirement is a Nvidia GTX 660 (released 2012)
The 8400GS was released in 2007 or so... For 60 € you can get a GTX 760/770 on ebay (a huge step forward... ; ))

@Pinus
I the support is based on OpenGL and 1 GB of VRAM, this card reaches both the 3.3 OpenGL version and the memory which I think is right in the edge of support.
Btw I know I need an update, but I've listened people working in similar hardware like this GTX 660... which also have this kind of problems.

Pinus added a comment.Fri, Sep 20, 1:40 AM

@ Sebastian
The problem is the driver and not so the tech specs.

My test/backup render-machine runs with Linux Mint 18.3 with a Nvidia GTX 660, and i have no problems
with 2.80/2.81 (slow but it works fine)

At the moment im on a other machine, so i cant check what driver-version is installed, but i think it is 384xxx
I dont know which driver-versions your Arch-Linux offers, but your installed driver 340.107 is the last for your
8400GS card, and i think you need minimum 384 for Blender 2.8x ...