Page MenuHome

Video Editor: Opening several Sequencer area instances will cause bad playback rate
Closed, DuplicatePublic

Description

Opening more sequencer timeline areas will cause bad playback rate, but in preview mode it doesn't.

Have a Video Editor area open with a Sequencer and Preview and notice the playback rate.
Open another Sequencer area and notice the drop in playback rate.
(Only Sequencer areas will have this effect, but not Sequencer Preview)

As seen in this gif:

Operating system: Windows-10-10.0.17763 64 Bits
Broken: version: 2.81 (sub 11), branch: master, commit date: 2019-09-14 14:25, hash: rB38cc53a168d2

Details

Type
Bug

Event Timeline

Peter Fog (tintwotin) renamed this task from Vide Editor: Opening several Sequencer(timeline) instances will cause bad playback rate to Video Editor: Opening several Sequencer area instances will cause bad playback rate.Sep 16 2019, 9:10 AM
Peter Fog (tintwotin) created this task.
Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 17 2019, 4:40 PM

I cannot reproduce it in my simple test case. Can you reproduce this with any video? A test file would probably be helpful.

@Jacques Lucke (JacquesLucke) It is properly dependent on how powerful your computer is. Mine is not very powerful, so I'm just using a 720p clip for the gif above, where the effect is quite visible. Maybe you could try with some 4k footage and keep adding sequencer areas while the video is playing(uncached) timeline in an area with sequencer+preview.

If you need some 4k footage, maybe some of this would work: https://www.pexels.com/free-4k-footage/

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Sep 17 2019, 9:22 PM

TBO Timelines have always been a resource hog.
And what's also demonstrated in your gif is moving the mouse over different elements causes the UI to draw at different frame rates...
ref: T60336#596645

Which editors are refreshed depends on where you start the playback. This is by design, and starting playback over the 3D viewport will generally be fastest.
Optimizations to animation playback of other editors are possible, but not considered a bug.

Not sure if this applies here, if on a per workspace or a per editor type...

Richard Antalik (ISS) closed this task as Invalid.Sun, Sep 22, 4:40 AM
Richard Antalik (ISS) claimed this task.

I can confirm, performance decrease with each timeline opened.

Obviously, resources are needed to draw each timeline area.
Overall I think, that VSE UI drawing code is in quite good condition with no obvious performance sinks.

Unless I am proven wrong here, I have to say, that you have either to upgrade hardware, or keep conservative editing layout.

This is actually a regression. In 2.79 this does not happen, as seen in this gif.
In 2.80 the fps is halved each time a new sequencer-timeline is opened.
In 2.79 the fps maybe drops at little(0.5 fps) or maybe not at all.

2.80:

Another thing to notice is that in 2.79 this same clip(720p) played at almost 24 fps(correct) and in 2.80 it played at 21-22 fps(not correct) with only one instance of sequencer-timeline.

Try disable cache bar on the bottom if that helps (no regression when I did that.)

That cache viewing thing is a bit resource intensive, but it was written with performance in mind.

Perhaps I can optimize iterating even more, but this will make code a bit more complex. Will have to think about this a bit.

Richard Antalik (ISS) reopened this task as Open.Sun, Sep 22, 10:33 PM
Richard Antalik (ISS) lowered the priority of this task from Needs Triage by Developer to Normal.