Page MenuHome

Display as Wire makes other objects disappear
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro 64-bit
Graphics card: NVIDIA GeForce RTX 2080 Ti

Blender Version
Broken: Blender 2.81 Alpha, September 19, 23:17:32 - c8df6f2cf9df

Short description of error
Wireframe 3D view mode makes certain objects disappear if they are displayed as Bounds or have certain wireframe characteristics, such as the Camera icon.

Exact steps for others to reproduce the error

  1. Make a copy of the default cube.
  2. Set one of the cubes to Object Properties ➔ Viewport Display ➔ Display As ➔ Bounds.
  3. Switch to wireframe view.
  4. The Bounds-displayed cube, the camera and the circle around the light disappear from the view.

This is very cumbersome if you've got objects set to Bounds to indicate dimensions during modeling in Wireframe mode.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 20 2019, 11:36 AM

Cannot reproduce here (linux, 970m, 435.21 drivers) from the repro steps provided

  • Does this happen with Factory Defaults?
  • Does this carry across save and reload?
  • if so, please share your .blend file here...

On my system (Windows 10 Pro 64-bit, NVIDIA GeForce RTX 2080 Ti) the behaviour is consistently reproducable.

  • Factory Default doesn't make the issue go away.
  • It carries across save and reload, and across different scenes.
  • Blend file attached.

Maybe it's useful info to add that I've got the latest non-official NVIDIA driver release installed, to get OptiX working in Blender.

Rolled back the driver to the latest official NVIDIA Studio Driver. Still the same issue.

I noticed that simply switching the 3D viewport to Wireframe mode already makes the following items disappear from the 3D view: the camera, the circle around the light and objects set to Bounds display.

I've adjusted my initial post accordingly.

Please try again with the very latest build, there were some fixes that may have helped here:
https://builder.blender.org/download/

Yes, it works correctly now! Thanks, nice work.

Brecht Van Lommel (brecht) closed this task as Resolved.Oct 3 2019, 9:33 AM
Brecht Van Lommel (brecht) claimed this task.