Page MenuHome

Mantaflow Gas sim does not use second emitter when third (particle) emitter added
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36

Blender Version
Broken: version: 2.81 (sub 3), branch: fluid-mantaflow (modified), commit date: 2019-08-27 23:26, hash: rB552149d8f537
Worked: (optional)

Short description of error
[made a gas sim with 2 mesh emitters, added another emitter using particles, then only one of the original mesh emitters works / creates smoke]

Exact steps for others to reproduce the error
[Bake the attached sim and view, then enable the 'muted' collection (and probably bake the particles again) and bake the domain again, you should lose one of the mesh emitters if it behaves like it is for me.
I noticed this before with another sim using 2 particle systems as emitters (when the second was added it stopped making smoke from the first), but just assumed this was particles being fairly broken in Blender 2.8x.
Here's my results- https://www.youtube.com/watch?v=iVOlAPERcuY&feature=youtu.be
On the left is the sim before adding the particle emitter, sorry for the low-rez render but sort of gave up when the issue occured...

]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from 90 to 80.
Bastien Montagne (mont29) edited projects, added Physics; removed BF Blender.

FYI: I made a couple of different sims yesterday- and neither did the above, so it's not happening every time.

zebus3d (ofuscado) added a comment.EditedJan 21 2020, 11:23 AM

I also tried two objects with two particle systems to emit smoke in the same domain, both in mac and linux and they don't work correctrly.
In Mac, only emits one of the particle systems, in Linux neither of them.

This looks OK in 2.82 as well-

Made a duplicate of the particle system in the scene used in T70175 and it baked OK so made another couple and they baked fine as well. Threw in a copy of the mesh emitter as well, all worked OK.

Aaron Carlisle (Blendify) closed this task as Resolved.Feb 18 2020, 1:34 AM