Page MenuHome

Video Editor: Regression in 2.80 stacked Scene-Strips gives poor playback fps
Closed, ArchivedPublic

Description

In 2.79 had correct playback fps (24) when playing a sequence containing two stacked scene-strips, and no preformance drop, as seen in this gif:


File:

In 2.80 the playback for one strip is around 8 fps and for two stacked scene-strips it drops to 4 fps as seen in this gif:


File:

System Information
Operating system: Windows-10-10.0.17763 64 Bit

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (2.79)

Details

Type
Bug

Event Timeline

Peter Fog (tintwotin) renamed this task from Vide Editor: Regression in 2.80 stacked Scene-Strips gives poorer playback to Vide Editor: Regression in 2.80 stacked Scene-Strips gives poor playback fps.Sun, Sep 22, 9:42 AM
Peter Fog (tintwotin) renamed this task from Vide Editor: Regression in 2.80 stacked Scene-Strips gives poor playback fps to Video Editor: Regression in 2.80 stacked Scene-Strips gives poor playback fps.
Peter Fog (tintwotin) updated the task description. (Show Details)

This hardly feels a like fair comparison...

  1. The resolutions are different
  2. The blend modes are different

Opening up TwoSceneStrips279.blend and setting it to something that taxes my system (in 2.79b) then opening up in 2.80.
gives me these results:

2.79b2.80

Here the 50% percent resolution doesn't have an effect on the fps. It is still 24 fps in the 2.79. The Blend mode does have an effect in both 2.79 and 2.80, however the question is if the transparency setting is off on the scene-strip and Opacity is set to 1, then the Blendmode shouldn't have any effect at all.

Setting 2.79 to Cross results in 24 fps and setting 2.80 to Cross results in 10 fps.

So the changed default Blendmode is one cause of regression, but it doesn't explain a difference of 14 fps(when using the 2.79 file), so something else must be the reason for this huge regression of the playback of scene-strips.

Here the 50% percent resolution doesn't have an effect on the fps.

Umm... what? I'm not talking about a 50% difference in resolution...

TwoSceneStrips279.blendTwoSceneStrips280.blend

The Blend mode does have an effect in both 2.79 and 2.80, however the question is if the transparency setting is off on the scene-strip and Opacity is set to 1, then the Blendmode shouldn't have any effect at all.

Right, this is being disscussed in and from T69334#780541

Setting 2.79 to Cross results in 24 fps and setting 2.80 to Cross results in 10 fps.

This doesn't say anything. Trying to create two .blend files with very different versions of Blender (i.e. the defaults), that have no connection with each other (the .blend files), is not how you do regression testing...

So the changed default Blendmode is one cause of regression, but it doesn't explain a difference of 14 fps(when using the 2.79 file), so something else must be the reason for this huge regression of the playback of scene-strips.

Well since you don't give your system specs... "Mine is not very powerful" and "It is properly dependent on how powerful your computer is" doesn't help us diagnose issues...

Bung it on your profile, that way you can easily copy and paste. Or save a bug report template like I have...


What were your numbers on the modded file? (Starting playback from the timeline, of course...)

I haven't read comments.

Is issue here stacking strips, or performance of scene strips?
Obviously if it's the later, regression would be amplified by number of strips, but that has nothing to do with the issue.

Peter Fog (tintwotin) closed this task as Archived.Wed, Sep 25, 1:31 PM
Peter Fog (tintwotin) claimed this task.

I'm closing this one.

The play rate drop was caused by having Alpha Over as default Blendmode. Which is reported here: https://developer.blender.org/T70227

And further investigation in the Scene Strip play rate regression is continued here: https://developer.blender.org/T70239