Page MenuHome

Batch Rename dialog gets added backslash (escapes valid characters)
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Windows 10 Pro 64-bit
Graphics card: NVIDIA GeForce RTX 2080 Ti

Blender Version
Broken: Blender 2.81 Alpha, September 22, 23:12:41 - 52bdf522afcd

Short description of error
Adding a blank space to a name in the Batch Rename dialog results in an added backslash in the resulting names.

Exact steps for others to reproduce the error

  1. Make a number of copies of the default cube.
  2. Select all Cube copies.
  3. Press Alt + F2 for Batch Rename dialog.
  4. Enter "cube" in Find field.
  5. Enter "cube 02" in Replace field.
  6. Press OK button.
  7. The resulting object names contain a backslash.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Tue, Sep 24, 1:16 PM

This is true when there is a blank space (numbers dont matter) in the Replace field (will update report accordingly).
This shouldnt be neccessary, checking...

Philipp Oeser (lichtwerk) renamed this task from Adding number to name in Batch Rename dialog gets added backslash to Adding blank space to name in Batch Rename dialog gets added backslash.Tue, Sep 24, 1:17 PM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)

It escapes all the characters in pattern except ASCII letters, numbers and _, see https://docs.python.org/3/library/re.html#re.escape

Philipp Oeser (lichtwerk) renamed this task from Adding blank space to name in Batch Rename dialog gets added backslash to Batch Rename dialog gets added backslash (escapes valid characters).Tue, Sep 24, 1:25 PM
Philipp Oeser (lichtwerk) closed this task as Resolved.Wed, Oct 9, 8:52 AM
Philipp Oeser (lichtwerk) claimed this task.

Good news: resolved, since rB95199dca1f12.

Hi,

The batch rename backslash issue is still there or is back.

I'm using today's build ( Blender 2.81 Alpha, October 11, 00:11:16 - f9cc51788bd6 ).

Regards,

Metin

Not in front of blender atm. need to check this again then (was working when I tried...)

Philipp Oeser (lichtwerk) raised the priority of this task from Confirmed, Medium to Waiting for Developer to Reproduce.Fri, Oct 11, 10:33 AM