Page MenuHome

System freezes completely on staring Blender 2.8 (Ubuntu using RX 5700)
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: Ubuntu 18.04 LTS and 19.04
Graphics card: Sapphire Radeon RX 5700 ("reference card")

Blender Version
Broken: tested (2.81 Alpha, 900a9a4b06a6, master, 2019-09-25) and (2.80 Release, 2019-07-30)
Worked: (2.79.b, 2019-09-24 last updated in repository)

Short description of error
If I try to open Blender the screen (to be more exact both of my screens) freeze. The audio of music or videos I had opened in other applications still play but everything is frozen except my mouse-cursor. But not a single window reacts to clicks or any key-presses. I can only end this state of my system by rebooting the whole computer. So I can't practically use the current version of Blender.

Exact steps for others to reproduce the error
If you have a Navi-GPU from AMD and their amdgpu-pro-drivers installed (which support Ubuntu 18.04) on Ubuntu 18.04 or 19.04, you should be able to reproduce it by executing the "blender" called binary from Blender 2.80. The other binary "blender-softwaregl" does not cause this error in any version tested but is rather slow in performance (but I guess this is expected).

My thoughts what causes the problem
The reason I post this problem around here and not only to the side of AMDs support fixing the drivers is that I think I know what's causing this problem. Because Blender 2.79 still seems to work fine on Ubuntu, I thought it could have something to do with Blender using Uniform Buffer Objects or even Shader Storage Buffer Objects from OpenGL in a wrong way. This thought came to me when I tried to develop an own application on my system using OpenGL 4.3 and its SSBOs in a shader but I made the mistake to call the shader before binding a SSBO to the appropriate Shader Storage Buffer Block. The result was the same error I got from calling Blender. So maybe it could just be fixed like in my own code by swapping some few lines in order which would remove this undefined behavior which causes this problem with the current Navi-drivers from AMD. Because I think AMD will probably need more time than you guys. Keep up the great work!

Event Timeline

Hi!
This seem directly related to the OpenGL support of your card in your environment. Using "Software-gl" is only using the CPU to do everything. Have you tried something else that require HARDWARE OPENGL on your system? It almost look like you don't have openGL drivers installed. Version 2.79 is less demanding for video card requirement and can almost run on anything.

I have installed the official drivers from AMD for Ubuntu which can be found here: https://www.amd.com/de/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-rx-5700

The problem with my graphics card is that it is really new and the most forums tell you need mesa 19.2 and Linux 5.13 installed at least. But Ubuntu got official drivers, so I could use a linux distro in a more stable way.

I have also a partition with Archlinux using the mesa-git repository but I get system wide freezes on it more randomly than on Ubuntu. So I stay with it until they release properly running drivers and firmware. What I could test on Arch so far seems to conclude that my 'problem' is mostly depending on the drivers. Blender 2.8 seems to run fine.

But since I had tested debugging my own lines of code and I got the same result, I thought I should report this problem. Because maybe it depends on a wrong/undefined use of OpenGL in Blender too.

Anyway to answer your question if something else using OpenGL runs:

  • "Tomb Raider" starts but does not render properly
  • "Witcher 2" runs fine without problems on high settings
  • "BioShock Infinite" starts but renders a black screen
  • "Counter-Strike: Global Offensive" is not responding
  • "Cities: Skylines" crashes
  • "HITMAN" runs perfectly on high settings
  • "Dota 2" runs fine using independent of using the Vulkan- or OpenGL-port
  • "Deus Ex: Mankind Divided" runs okay (performance is playable I guess but no problems)

These games should all make use of OpenGL on linux as far as I know.

Presumably this is an issue to be fixed in the AMD driver. @Jeroen Bakker (jbakker), maybe they are already aware of it?

I also see a new driver was released November 5, maybe that one helps.

I tried the new driver which was released November 5. But it did not help... Blender 2.8 still causes a system wide freeze.

Blender doesn't use SSBO as that is an OpenGL4.3 feature, so not sure that is related. We currently don't have any NAVI card to actually test or reproduce this issue. But let's see what we can do remotely.

First let us check if we have already a workaround in place, but it does not kick in for this specific platform.
can you see if you can start Blender with --debug-gpu-force-workarounds parameter.
This will enable all the workarounds that we currently have.

By doing so it also outputs some basic strings from your driver to the console. Can you post them here.

As you have an OpenGL4.3 context can you try to start Blender with --debug-gpu perhaps we can detect how far it gets.

and at last can you provide us with your system-info.txt.

blender --debug-gpu-force-workarounds --python-expr "import bpy; bpy.ops.wm.sysinfo(filepath=r'system-info.txt')"

If this one doesn't work use blender 2.79 to create the system-info from the Help menu.
I will check with AMD if they know something that we don't.

So I tried to use the --debug-gpu-force-workarounds parameter but it still caused a freeze. I could only get any output from blender via terminal:
blender --debug-gpu-force-workarounds > debug-gpu-force-workarounds_2.80.txt

The output from --debug-gpu doesn't tell much.. it seems like Blender is creating textures in different sizes. I guess the problem depends on the first test/call after that.

I couldn't get the system-info from Blender 2.80. I guess the GPU hangs before it can write the information to a file or even execute the python code. But I got the information from Blender 2.79. Maybe this will help.

Germano Cavalcante (mano-wii) lowered the priority of this task from 90 to High.Nov 8 2019, 4:43 PM

I dare to set this report as a high priority as it is a serious issue and more than one person has been able to reproduce it.

As long as a developer is not able to reproduce it it is unlikely that there will be much effort in fixing this. Don’t think we will postpone the release for this. Medium might be more appropriate

Germano Cavalcante (mano-wii) lowered the priority of this task from High to 50.Nov 8 2019, 8:39 PM

Seems like there might be a version conflict here.
NAVI required Linux version 5.3; Ubuntu 18.04 will use kernel 5.3 in the upcoming maintenance release (February 2020).

I haven't been able to install the proprietary drivers on my xubuntu 18.04.03 system. So haven't been able to confirm if this is actually an Blender issue at all, or just that it is howto configure a supporting stack using Ubuntu and 5700 at all? Also as other applications also have support issues as mentioned above.

For now I will continue testing how to setup a correct stack. But seems like a waste of time unless it is actually a Blender related issue.

isn't ubuntu 19.10 running on 5.3?

I just received confirmation that the next release of the AMD pro drivers would fix this issue. So keep an eye open for AMD Pro Drivers 19.40. I will keep this ticket open until it has been validated.

Jeroen Bakker (jbakker) changed the subtype of this task from "Report" to "Known Issue".Jan 10 2020, 12:37 PM

I set this to a known issue. Navi and Linux has issues and until it is in a better shape we cannot do anything from our side.

There are new AMD drivers (19.50) that have fix a lot of the original issues. Not completely fixed but a huge step forward.

Clément Foucault (fclem) changed the task status from Confirmed to Needs Information from User.Jul 1 2020, 11:47 PM
Clément Foucault (fclem) triaged this task as Low priority.
Clément Foucault (fclem) moved this task from Backlog to Known Issues on the EEVEE & Viewport board.

Can we have an update on this one? Do 2.81.1 & 2.90 with latest mesa works?

Hi Clement, currently using 5.4.0-39-generic #43-Ubuntu with no AMD drivers running 2.83.1 with no issues.

To my knowledge this could be closed. My dev station at BI uses this configuration

.
Note that there is a Bug in Mesa what is tracked at T76389: GPU Driver Issue: Animation Playback (MESA+AMD NAVI) what is the only open issue I am aware of. Because of this I switched to the AMD Pro Drivers.

Clément Foucault (fclem) closed this task as Resolved.Jul 3 2020, 2:35 PM
Clément Foucault (fclem) claimed this task.