Page MenuHome

Can not select amarture after add.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro 64-bit
Graphics card: Intel(R) HD Graphics 4000

Blender Version
Broken: blender 2.8
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked:

Short description of error
I have try to add a amarture into blender by rigify add-on. But after add, I cannot select the amarture anymore, I can choose it in outline panel and enter Edit mode, but still can't choose the bone. It have a same bug when I add 2 same Empty object into 1 file. I have try to Load Factory Setting but not hope. Please help!
Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 30 2019, 3:54 PM

Not sure I follow correctly:

  • your file only has the metarig, are we talking about that?
  • if this is in fact about the metarig, then I cannot reproduce (I can enter editmode and select bones without problem...)
  • Could you try with a fresh build from https://builder.blender.org/download/? [you havent said which exact version of blender you were using...]
  • If this is still not solved, could you try to explain in detail which bones cannot be selected, if this is in the viewport or outliner, ... maybe a video or screenshots could help here.
  • if this is more about the actual rig that gets generated, can you select the bones in editmode by clicking on their edges/wireframe? (then this might be the same as T67208)

I have download the latest version from blender.org yesterday.
When I add a metarig, it were selected then, after that I unselect it, I can't select it without drag on the ogirin. Then I go into edit mode, the only bone can choose is the spine bone. If I select it (by click or drag), all bone were selected. It's the same problem in pose mode.

Here the video capture about the bugs.

Hello,

Can't reproduce here

Your video is not using latest build (seen on your splashscreen, and some icons changed between 2.80 and now), and not using factory settings.
Please test again with factory settings and with latest build

No. I have redownload the lastest and re-install it. And I have already try the factory setting. But the bug still occur.

Oh, I found. I have try to change the display of amarture into Wire. So that I can select any bone I want.
Then I download the 2.81 beta and all of problem is fixed.
Thank you for all.
(But can anyone tell me why that bug appear in old version?)

Philipp Oeser (lichtwerk) closed this task as Resolved.Oct 1 2019, 3:35 PM
Philipp Oeser (lichtwerk) claimed this task.

That might be because (just noticed) your GPU is not officially supported (has to be Haswell and up)

https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/
https://en.wikipedia.org/wiki/List_of_Intel_graphics_processing_units

There are some workarounds in place, so you are lucky it works in 2.81 beta.

Anyways, thx for getting back, will close as resolved then...