Page MenuHome

Blender 2.81 Alpha on macOS 10.14.6 crashes upon launch starting with ff10ff782bde
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel HD Graphics 4000 OpenGL Engine Intel Inc. 4.1 INTEL-12.9.22

Blender Version
Broken: version: 2.81 (sub 12), branch: master, commit date: 2019-09-30 22:45, hash: rBff10ff782bde
Worked: (optional)

Short description of error
Blender 2.81 Alpha on macOS 10.14.6 crashes upon launch, starting with ff10ff782bde, 60a827a2a991 has it too. The crash.txt contains:

backtrace

0 blender 0x000000010e684e67 BLI_system_backtrace + 55
1 blender 0x000000010e3a724a sig_handle_crash + 362
2 libsystem_platform.dylib 0x00007fff596b1b5d _sigtramp + 29
3 ??? 0x0000000000000000 0x0 + 0
4 blender 0x000000010e3fe31a blo_do_versions_280 + 25786
5 blender 0x000000010e3bb3b5 do_versions + 245
6 blender 0x000000010e3ae39e blo_read_file_internal + 6734
7 blender 0x000000010e3a7f1d BLO_read_from_file + 61
8 blender 0x000000010e45a297 BKE_blendfile_read + 71
9 blender 0x000000010e8b8da9 wm_homefile_read + 2009
10 blender 0x000000010e8c101a WM_init + 346
11 blender 0x000000010e3a39c5 main + 757
12 libdyld.dylib 0x00007fff594c63d5 start + 1

Exact steps for others to reproduce the error
Just try launching the application. Double clicking it in the Finder or even in the Terminal using /Applications/Blender.app/Contents/MacOS/blender --factory-setup

Details

Type
Bug

Event Timeline

Bastien,

This morning I downloaded the most recent Daily Build, version rB0812949bbc3d and found that it had the exact same problem. I tried launching it using the Terminal with a --factory-setup, still crashed right upon launching.

But when I take the macOS route and delete:

~/Library/Application Support/Blender/2.81

The Daily Build opens up again! So the --factory-setup doesn't delete those preferences and settings files and give Blender a true factory settings clean start.