Page MenuHome

Batch Rename Key-bind (Alt+F2) conflicts with OS default keyboard shortcut
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.0.0-30-generic-x86_64-with-Ubuntu-19.04-disco 64 Bits
Graphics card: Radeon RX 580 Series (POLARIS10, DRM 3.33.0, 5.0.0-30-generic, LLVM 8.0.0) X.Org 4.5 (Core Profile) Mesa 19.0.8

Blender Version
Broken: version: 2.81 (sub 13), branch: master, commit date: 2019-10-02 21:39, hash: rB93e8c962fcc1
Worked: -

Short description of error
The default shortcut Alt+F2 for Batch Rename conflicts with the system-wide shortcut for Run Command on Systems running Ubuntu or the GNOME Desktop Environment and has been using that keyboard shortcut since the early 2000's. Being system-wide, it doesn't matter if Blender is in focus or not, the OS shortcut will take precedence over Blender's.

Exact steps for others to reproduce the error
Open blender
Select multiple objects
Hit Alt+F2 to Batch rename
OS Dialog for Run Command appears instead.

Event Timeline

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Oct 3 2019, 5:26 PM

I can't reproduce the problem on windows.

IMO not a bug, can confirm Alt+F2 conflict with similar MacOS function in Linux/KDE

i already tell this unofficially to Campbell on chat.blender UI channel, if i remeber correctly

I use Alt+F2 a lot on Manjaro KDE, not only for launching programs, but as calculator, convert measures, currency, time zones, translations, searching docs, etc.

My solution was to change the batch rename hotkey to Meta+F2.

Philipp Oeser (lichtwerk) closed this task as Archived.Oct 4 2019, 11:25 AM
Philipp Oeser (lichtwerk) claimed this task.

I would also think this would not be considered a bug, for example we also have the conflict with ALT+LMB and certain window managers.
The ALT+LMB thingie is mentioned in the manual though (https://docs.blender.org/manual/en/latest/getting_started/installing/linux.html#avoiding-alt-mouse-conflict).

Maybe we should mention the ALT+F2 there as well? CC @Campbell Barton (campbellbarton) ?

Anyways, will close this as not-a-bug (since you can always remap this inside blender or the OS).

Would remapping to Ctrl-F2 resolve this? (does this conflict on macos/windows?)

Would remapping to Ctrl-F2 resolve this? (does this conflict on macos/windows?)

No conflicts here.
Windows-10-10.0.18941 64 Bits

To my knowledge, macOS itself does not make any use of function keys. Cmd F2 is free.