Page MenuHome

dragging collections in and out of other collections make them hidden/visible inconsistently
Closed, DuplicatePublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: Radeon RX Vega M GH Graphics ATI Technologies Inc. 4.5.13543 Core Profile Context 25.20.15003.5010

Blender Version
Broken: version: 2.81 (sub 12), branch: master, commit date: 2019-09-23 20:20, hash: rB5a6ab6f59468
Worked: (optional)

Short description of error
See the attached GIF animation

Exact steps for others to reproduce the error
See the attached GIF animation

Details

Type
Bug

Event Timeline

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

I can confirm.

Steps to Reproduce:

  1. With the default startup file, uncheck the existing collection;
  2. Create a new collection for Scene Collection;
  3. Move the unchecked collection to the new collection.
Dalai Felinto (dfelinto) closed this task as Invalid.Mon, Oct 7, 7:42 PM

Hi Manu, thanks for the report.

However this as it is is by design. You moved something inside a disabled collection. It is not clear what you would expect (to enabled the disabled collection?)

It is consistent enough and the rule is: "A collection is disabled if dragged inside a disabled collection" that's all there is to it.

@Dalai Felinto (dfelinto) So what's supposed to happen when you drag the newly disabled collection out of the disabled collection?
The outliner shows the collection disabled, but the objects are visible...
I think that's what the report is about :)

Oh I see it, what should happen is the objects should still be invisible even after the collection was dragged outside (since the collection actually is still disabled - saving and reopening the file shows the correct expected behaviour.

Hi Dalai and Christopher,

Yes my main concern was that when the collection is disabled, the object inside it is visible in the viewport, that is inconsistent in my mind. And there are two instances where this behavior happens.

I think it's hard to explain, but the gif shows it quite clearly.

But of course, this is no biggie :) Thanks anyway!