Page MenuHome

AMD 5700 XT not working with Blender 2.8 (linux)
Closed, DuplicatePublic

Description

System Information
Operating system: 5.0.0-31-generic #33~18.04.1-Ubuntu SMP Tue Oct 1 10:20:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Graphics card: 5700 XT

Blender Version
Broken: blender-2.81-ab519b91b2c4-linux-glibc217-x86_64
Worked: (optional)

Short description of error
Blender and system will lock before splash screen is displayed - hard reset required

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

repeatable after installing amdgpu-pro-19.30-855429-ubuntu-18.04 drivers... installed using amdgpu-pro-install script

functional with amdgpu-install script but no openCL GPU recognised

Details

Type
Bug

Event Timeline

It will be fixed in next build.

If you need any further testing happy to help.

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Oct 8 2019, 5:03 PM

We need a developer with the same GPU to reproduce the problem.
In the meantime you can check if the driver installed is the most up to date on the AMD website.

I may be wrong but from system-info it seems that the OpenGL driver is not even installed.

Same issue with 5700 and AMDGPU-PRO. Recently reported on another bug by me.

I can send my 5700 to a developer if they need it to fix this.

update:
OS : 5.3.0-19-generic #20-Ubuntu SMP Fri Oct 18 09:04:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Blender Version:
Working 2.80
Broken 2.81 Runs application but will halt system when loading complex .blend (mr_elephant for example)

Description:
updated to using 5.3 Kernel Blender working but slow.
followed following guide :
https://ubuntuforums.org/showthread.php?t=2425799
credits to Claritux

OpenCL still not recongnised but blender is very usable.

(...)
OpenCL still not recongnised but blender is very usable.

The attached system-info.txt reports 1 device with OpenCL detected.
Do you mean OpenGL?
Anyway it would be pretty hard for blender to be usable without OpenGL.

Was the original issue fixed? If this is the case the report can be closed.
Any other issues should be reported separately.

Nope, same issues. Have gone back to previous GFX card until better support is available.