Page MenuHome

Cyles Branched Pathtracing integrator changes diffuse colours of objects
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.70

Blender Version
Broken: version: 2.81 (sub 13), branch: master, commit date: 2019-10-04 22:33, hash: rBab519b91b2c4
Worked: 2.80 release

Setting the integrator to branched pathtracing ( I used CPU) changes diffuse colors of objects in file "barbershop_interior_cpu.blend" from https://www.blender.org/download/demo-files/

Pictures of the render error can be seen here:

https://imgur.com/a/uaJ34FV

Exact steps for others to reproduce the error

Set the integrator to branched and hit render.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.Oct 7 2019, 9:32 AM
Brecht Van Lommel (brecht) claimed this task.

When using certain tricks like clamping and light path nodes, the results will be different for different integrators. This is not a bug in itself.

There may be a bug here, but if there is one we require the bug reporter to provide an as simple as possible .blend file to reproduce the problem, we are not going to spend time investigating a production file just in case.

Just to be sure that we are talking about the same issue:

This is current master BPT:
https://imgur.com/a/rs3F4Vv

This is how it looked in 2.8 BPT :
https://imgur.com/a/xYKHIdU

I know that pt and bpt will look ever so slightly different dy default but this is not what i am reporting.
The difference I am reportingis between BPT of 2.8 and 2.81.

The scene contains an optimisation to Bump Mapping in the "SH-DiffuseGlossy" Nodegroup.

If you disable the optimisation you get this result:

https://imgur.com/a/SfzWb4T

This is a lot closer but not identical who it looked in 2.8 BPT :
https://imgur.com/a/xYKHIdU

Bug is also present in current 2.82 alphas.
Maybe for consideration:
I never really use BPT to dial in samples manually but rather because the feature "SAMPLE ALL LIGHTS" reduces noise on SSS and multiple lights greatly.
I think most people who use motion blur will need fairly high AA sample anyway.
If SAMPLE ALL LIGHTS was available in regular PT mode and gave similar results as in BPT, I personally would have little incentive left to ever use branched at all.

More tests on current 2.82 alpha:

WIN10 BPT CPU: Glitched funky colours
WIN10 BPT GPU CUDA: Correct image
Ubuntu (VM) BPT CPU: Correct image

CPU is Ryzen 3900X.
Maybe it is complier related problem? Worked in 2.80 release.
I will test tomorrow on Skylake CPU to rule out hardware specific problem.

WIN 10 BPT Skylake CPU: Glitched funky colours

Apparently the issue dissapears if you just render the image for second time.

So far:

  • Glitched colours in BPT only appear on builds after 2.80 release
  • Only WIn10 seems affceted (Linux works, OSX not tested)
  • Only CPU device seems affected, at least CUDA works fine
  • Render errors disappear on CPU BPT render if you render for a second time

The CUDA device also produces glitched images on WIN10 if it is the first render!
So the error is not only on CPU device on WIN10.

Just rechecked and it was also glitched in 2.80 release on WIN10.