Page MenuHome

Unable to select mesh objects in viewport, and edit mode not displaying overlays
Closed, DuplicatePublic

Description

System Information
Mac OSX 10.13.6
Operating system: Darwin-17.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX TITAN X OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-10.33.0 387.10.10.10.40.129

Blender Version
Broken: version: 2.81 (sub 14), branch: master, commit date: 2019-10-06 14:05, hash: rB54a9649e2636
Worked: 2.8 official

Short description of error
Object selection not working always in viewport (RMB) and edit mode engaging but not displaying geometry (yes the overlays are on ;)

Can't select mesh objects in viewport, only in outliner. Works momentarily on file load, but switching modes breaks it again.

In edit mode, geo overlays not displaying, or selectable. This includes geometry>wireframe, normals, possibly others.

Tried resaving the file in 2.8 and loading in 2.81, but that didn't help.

Exact steps for others to reproduce the error
Load .blend
Try selecting mesh objects (might be selected initially), can select empty, cameras, lights, not meshes.
Select body mesh in outliner
enter edit mode
no geometry displayed

Event Timeline

Is it file specific behaviour or does it happen with new file too?
I have a problem with similar symptoms https://developer.blender.org/T70516
Did you touch metaball object in your process?

I just tried with a new file, just deleting the cube and adding a Suzanne, and had similar behaviour after deselecting, selecting and entering edit mode. Object selection seems to work but only selecting right next to the origin, not on the object itself, which isn't the case in 2.80. And edit mode behaviour--lack of any geometry overlay is the same. So, no metaballs needed ;)

Just tested in the new daily build, and it looks like it's ok now. Will update here later if the problem resurfaces. Thanks!

It's still happening, intermittent, but still there. Quite a few issues happening quite randomly, objects disappearing, not selectable or not editable. I'll try to fit more testing in soon.

I am finding sometimes that these drawing issues clear up once I quit and reopen Blender, but not reloading files.

Germano Cavalcante (mano-wii) lowered the priority of this task from 90 to 80.Oct 9 2019, 2:41 PM

We are aware of many issues on MAC OS, but unfortunately we have no developers with this setup to investigate and reproduce the problem.
When Blender supports Vulkan, many of these problems will likely be solved.

filip mond (vklidu) added a comment.EditedOct 28 2019, 8:50 PM

Since "Origins" (viewport overlay) enabled - objects starts to work (selection, visibility) as expected.
Disabling this option bring back issue in your document.

Óscar (Oxer) added a subscriber: Óscar (Oxer).EditedNov 12 2019, 7:43 AM

I have the same problem on macos 10.13.6 & Blender 2.81.16. This happens randomly but a lot of times. Can't select object in the viewport and the navigation controls icons disappear, black circles are shown only.
Sometimes when I change between workspaces or panels, other times when I change of mode (ie Object Mode to Edit Mode). I found a momentanius solution but it's not work all the times, the solution is to change between Editing to Layout workspaces and vice versa.
With this issue it's very difficult use Blender, you have to quit and reopen Blender to continue working ( when the previous solution doesn't work).

Same problem here since a few weeks with 2.81b and 2.82a. (macOS 10.13.6 + GTX1080Ti)
Objects suddenly disappear from viewport in EEVEE and Lookdev, displaying only outline when selected.
T71147 seems related.

Same Problem here. I am only able to select objects in the outliner. When i click anywhere in the viewport it de-selects everything.

Same Problem here. I am only able to select objects in the outliner. When i click anywhere in the viewport it de-selects everything.

nevermind. i am stupid. tried to select an instanced object with the instancer hidden. : |