Page MenuHome

smooth shading doesn't appear work at all in both cycles and EEVEE
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.81 (sub 14), branch: master, commit date: 2019-10-06 14:05, hash: rB54a9649e2636

Short description of error
Just thought I'd try moving some of my commercial work over to Blender, but I seem to be having a problem where smooth shading doesn't appear to be working, most prominent with a normal map, but still visible without. Geometry appears to be OK, no sharp edges etc, normals fine, auto smooth tried on and off, made sure there's no custom split normals data etc.

I've tested the same geometry in Redshift/Houdini, and it seems to be fine.

Exact steps for others to reproduce the error
open file and press render:

Details

Type
Bug

Event Timeline

Just thought I'd try moving some of my commercial work over to Blender...

Via Alembic import, perchance? See T70710. See also T69182. Thank you in advance for any clarification!

Just thought I'd try moving some of my commercial work over to Blender...

Via Alembic import, perchance? See T70710. See also T69182. Thank you in advance for any clarification!

No, this was an obj. Also tried with fbx, and even tried modelling it directly in Blender, but the result was identical in each instance.

forgot to mention, I tried disabling shadows on the light source, but the issue was still there, so not a shadow related issue.

I see this problem, i resolve it moving Bump output from Normal to Tangent Principled BSDF input

I see this problem, i resolve it moving Bump output from Normal to Tangent Principled BSDF input

The issue is still visible even without a normal map, so whilst the normal map accentuates the issue, it's not the cause in my case.

I can reproduce this on default Blender's cylinder and sphere with procedural Checker and Noise textures and without any textures at all, Bump makes the problem more prominent.

Brecht, one of those is closed, and the other is related to shadows? I'm getting this problem with shadows turned off, so I'm not sure if you've closed this in error?

It's the same issue, also without shadows the discrepancy between actual and smooth normal causes artifacts. BSDFs by themselves also include shadowing terms.

It's the same issue, also without shadows the discrepancy between actual and smooth normal causes artifacts. BSDFs by themselves also include shadowing terms.

Brecht, might be worth speaking to Ondra over at Corona. They fixed the same issue around 4 years ago. They have no plans to come over to blender, so he'd probably be happy to offer you some guidance if you're struggling.

We have ideas for how to solve it, just a matter of finding the time.

We have ideas for how to solve it, just a matter of finding the time.

I'll try and find out for you, you won't need as much time if you know how to do it. Jules Urbach might be willing to help if Ondra can't. Do they already have your contact details?

If you can get them to publish their method publicly that would help. Sending it to me or other developers personally is not enough, it must be clear that they are the ones sharing this information publicly for anyone to use.

hmm, should be possible, I think everyone else has resolved the issue years ago, so I can't see them being worried about helping the competition. Although I see you've been struggling to resolve it since 2013, so perhaps it required a bohemoth amount of manpower to figure out, in which case they might not be willing... we'll see. I'll send you a link if anyone agrees.

Can you give me the exact terminology of the issue, so I can pass on the problem correctly.