Page MenuHome

eevee performance drop with node tree in 2.81
Closed, DuplicatePublic

Description

System Information
Operating system: Linux-4.13.10-041310-generic-x86_64-with-debian-stretch-sid 64 Bits
Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.67

Blender Version
Broken: version: 2.81 (sub 14), branch: master, commit date: 2019-10-10 23:31, hash: rBf9cc51788bd6
Worked: (optional)

Short description of error
Maybe related to this recent issue, I have another node tree that seems to affect eevee performance quite significantly.

Exact steps for others to reproduce the error

  • open the attached blend file in 2.80 and drag any of the principled shader's inputs, like metallic or roughness, it should be smooth
  • repeat in a recent 2.81 build, it should be sluggish

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Can confirm a performance difference.
@Clément Foucault (fclem): this expected? (I know there's changes to bump and tree traversal, but this also seems to affect trees not even connected to normal slot... but I guess the traversal runs regardless...)

Well I guess it's a duplicate of T70325 which has already been resolved. Feel free to reopen if that's still a problem. Note that the new bump mapping increase the shader/nodetree complexity so it will never be on the same level as 2.80.

MACHIN3 (MACHIN3) added a comment.EditedOct 15 2019, 2:58 PM

T70325 was also reported by me and seems to be resolved to me. This one here is not however. It also doesn't seem like it is related to bump, unless I misunderstand you. I can pipe the node tree into the roughness slot as well and it's just as sluggish.

It doesn't look like i can reopen this task, but I think it's very unfortunate if this slow down can't be resolved. I'll see if I can pin point the issue to any specific node or node combination in the tree.