Page MenuHome

Right Click CrashOSX 10.14.8 Blender
Closed, ArchivedPublic

Description

System Information
Operating system: OSX 10.14.8 27" iMac AMD Radeon R9 M390 2 GB
Graphics card:

Blender Version 2.80 (2.80 2019-07-29

Unable to select objects in 3D view.

Attribute Error: 'SpaceView 3D object has no attribute value."

Occurs when trying to select an object when Blender Preferences-->Keymap-->Select With is set to Right.
The whichever mouse button is set as "Primary Mouse Button" in the iOS preferences positions the origin. The other mouse button produces the error.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 12 2019, 9:43 PM

I am finding this very hard to follow. Blender isn't available for iOS, so I'm not sure why the reference to iOS preferences make sense here.

Blender has been available for OSX for years (and has worked very well).

I obtained the current version from https://www.blender.org/download It is available. It does run on OSX. And, at least for me, it has the bug I described.

It runs on macOS, but not iOS.

Ooops. That should have been "OSX preferences."

Well technically it's called macOS now. It hasn't been OSX for a number of years now.

But anyway, still find this hard to follow. If you set the Primary mouse button setting to Right in macOS System Preferences;

Why are you then also setting the Blender Select With setting to Right? The two will naturally cancel each other out.

And, if you set them both to "Right" A Right click sets the Origin, and a Left Click produces the error. (And the error was the problem for me, since it took a while to figure out the cause. I found it natural to think that if the Blender Select With preference was set to Right, Blender would select with a right click. I would not have thought the natural setting would be for the Mac Preference to be set to Right and the Blender preference set to Left.

It seems to me this is a problem in the underlying Python, which should be able to interpret setting Select With to Right, and not produce an error. I am glad to see that Blender is moving to align with the rest of the world in the default setting for Left Click Select. But, for an application that for so long has been committed to Right Click Select, it seems to me this is a bug worth fixing.

Are you using the factory default keymap? I cannot reproduce your issue, even if I don’t follow what you are trying to do and why.

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Nov 6, 5:13 PM
Brecht Van Lommel (brecht) claimed this task.

I think there is an issue in the keymap here, maybe something was accidentally assigned to mouse press. The left/right preferences are probably a red herring.

I suspect this was another instance of T65397, which was solved in 2.81.

If the issue still happens with 2.81, and a factory default keymap, then we can investigate. But without that I don't see much information to go on.