Page MenuHome

Library Override dissabled after re-instancing same collection in different scene.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.35

Blender Version
Broken: version: 2.81 (sub 15), branch: master, commit date: 2019-10-11 19:43, hash: rB60d02b336eaf

Short description of error
When linking the same collection to multiple scenes using library overrides, the "chain with an arrow," icon next to the objects disappears, and the UI doesn't recognize it as an override (IE: No blue property boxes).

I've only tested it on small test scenes, so I don't know all the side effects of this, but one side effect that I noticed is that if you change the origin of an object in the original library collection, then the objects with the override icon will stay in the same location (as they should), but objects that lost the icon will be adjusted so that their new origin is at the same point the old origin is.

Exact steps for others to reproduce the error

  1. Create a library file with a collection.
  2. Create another file and link the collection from step 1.
  3. Make library override of that collection
  4. Create another scene, link the collection, and make it an override.
  5. Go back to the first scene and there is no longer a chain + arrow next to the objects.

Event Timeline

Zach Hixson (zachThePerson) renamed this task from Library Override icon dissapears after re-instancing same collection in different scene. to Library Override dissabled after re-instancing same collection in different scene. .Oct 14 2019, 12:03 AM
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Confirmed, overriding collection in first scene somehow loses its (linked) reference when overriding in second scene…