Page MenuHome

Export FBX error with more then 2 layer parent object.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
When i export fbx file with more then 2 layer parent object, fbx will lost this object.
My object:

Export FBX:

Exact steps for others to reproduce the error
Error file is here:

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 14 2019, 10:00 AM

As you can easily check by re-importing back same FBX into Blender, your third object is not lost at all.

Not sure what viewer you are using, but please at least check with either Blender itself, or some reference app like Maya…

Also, please always try the latest build from our buildbot before reporting a bug.

I import the fbx into Unity, and the object is lost.
And I try to use 95f020c853d6-windows64 can reproduce this problem.
import unity:

in blender:

windows 3d viewer:

Well then… Again, would be best to check with ref app like Maya (in the odd case that Unity would not support multi-level parenting), but besides that, I don’t know what to say… Afaik this has never been an issue before, nothing changed in that code since ages, I would expect it to have been reported already if that had been an issue. :/

I try to use blender-2.82-a8d001fef5e8 to reproduce this problem.

  1. Create three box, and set parent one by one

  1. Select all box to fbx and apply transform.

  1. Import the fbx file into scene


So, the last child box dimensions become 0.02(before export all box dimensions is 2), and the position become too close 0,0,0
And I upload the export and re-import video here.

If the object whth only one layer parent, is all OK. But if more than one , after export it have a error translation.

And I import the fbx into maya and the problem as before.
And screenshot here.



Bastien Montagne (mont29) closed this task as Archived.Oct 16 2019, 3:18 PM
Bastien Montagne (mont29) claimed this task.

So… the '!EXPERIMENTAL! ' warning on that setting (Apply Transform) was removed by accident at some point, it has now been restored. Fact is, that feature/option is known to only work in a very limited cases, and parenting is not supported for that here. So thanks for the report, bug no bug here, just some known limitation.